summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 11:25:41 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 11:25:41 +0000
commit725a3035d54197c22c7b3db707bf8d9af115efca (patch)
tree91621f07d5b1d5912c36d5463aa867dbd0bbbc6e /app-editors
parent*** empty log message *** (diff)
downloadhistorical-725a3035d54197c22c7b3db707bf8d9af115efca.tar.gz
historical-725a3035d54197c22c7b3db707bf8d9af115efca.tar.bz2
historical-725a3035d54197c22c7b3db707bf8d9af115efca.zip
*** empty log message ***
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gtk-xemacs/gtk-xemacs-21.1-r1.ebuild30
-rw-r--r--app-editors/joe/joe-2.8-r1.ebuild48
2 files changed, 78 insertions, 0 deletions
diff --git a/app-editors/gtk-xemacs/gtk-xemacs-21.1-r1.ebuild b/app-editors/gtk-xemacs/gtk-xemacs-21.1-r1.ebuild
new file mode 100644
index 000000000000..778be4f4dad0
--- /dev/null
+++ b/app-editors/gtk-xemacs/gtk-xemacs-21.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gtk-xemacs/gtk-xemacs-21.1-r1.ebuild,v 1.1 2000/08/07 11:25:41 achim Exp $
+
+P=gtk-xemacs-21.1
+A=gtk-xemacs-cvs-000611.tar.bz2
+S=${WORKDIR}/gtk-xemacs
+CATEGORY="app-editors"
+DESCRIPTION="XEmacs 21.1 GTK"
+SRC_URI="ftp://gentoolinux.sourceforge.net/pub/gentoolinux/current/distfiles/"${A}
+HOMEPAGE="http://www.cs.indiana.edu/elisp/gui-xemacs/"
+
+src_compile() {
+ cd ${S}
+ ./configure --prefix=/usr/X11R6
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr/X11R6 install
+ prepinfo /usr/X11R6/lib/xemacs-21.1.10
+ prepman /usr/X11R6
+ dodoc BUGS CHANGES-beta COPYING GETTING* INSTALL ISSUES PROBLEMS README*
+}
+
+
+
+
diff --git a/app-editors/joe/joe-2.8-r1.ebuild b/app-editors/joe/joe-2.8-r1.ebuild
new file mode 100644
index 000000000000..3502196afd1e
--- /dev/null
+++ b/app-editors/joe/joe-2.8-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.8-r1.ebuild,v 1.1 2000/08/07 11:25:41 achim Exp $
+
+P=joe-2.8
+A=joe2.8.tar.Z
+S=${WORKDIR}/joe
+CATEGORY="sys"
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+SRC_URI="ftp://ftp.std.com/src/editors/"${A}
+
+src_compile() {
+
+ make
+ make termidx
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${O}/files/joe2.8.dif
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin joe
+ doman joe.1
+
+ for i in jmacs jstar jpico rjoe
+ do
+ dosym /usr/bin/joe /usr/bin/$i
+ dosym /usr/man/man1/joe.1.gz /usr/man/man1/$i.1.gz
+ done
+
+ dobin termidx
+ dolib joerc
+ dolib jmacsrc
+ dolib jstarrc
+ dolib rjoerc
+ dolib jpicorc
+ dolib termcap
+ dolib terminfo
+}
+
+