summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-11-08 03:46:50 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-11-08 03:46:50 +0000
commita5567295cff74e2818607e3191d521ff91576203 (patch)
tree26ede6362d9ea98407847bfc4fd37195efea1c3e /app-editors
parentremoved package mask for vim... using ARCH masks (diff)
downloadhistorical-a5567295cff74e2818607e3191d521ff91576203.tar.gz
historical-a5567295cff74e2818607e3191d521ff91576203.tar.bz2
historical-a5567295cff74e2818607e3191d521ff91576203.zip
Arch mask the new vim
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-6.1-r3.ebuild4
-rw-r--r--app-editors/vim-core/ChangeLog6
-rw-r--r--app-editors/vim-core/vim-core-6.1-r3.ebuild24
-rw-r--r--app-editors/vim/vim-6.1-r16.ebuild4
4 files changed, 17 insertions, 21 deletions
diff --git a/app-editors/gvim/gvim-6.1-r3.ebuild b/app-editors/gvim/gvim-6.1-r3.ebuild
index ab2d69838642..e7f9c78bc657 100644
--- a/app-editors/gvim/gvim-6.1-r3.ebuild
+++ b/app-editors/gvim/gvim-6.1-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r3.ebuild,v 1.2 2002/10/28 07:20:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.1-r3.ebuild,v 1.3 2002/11/08 03:46:50 rphillips Exp $
inherit vim
DESCRIPTION="graphical vim"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="dev-util/cscope
>=sys-libs/ncurses-5.2-r2
app-editors/vim-core
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 870dae43c5c7..b1dbf2b67eed 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.4 2002/10/27 22:52:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.5 2002/11/08 03:45:57 rphillips Exp $
*vim-core-6.1-r3 (27 Oct 2002)
+ 07 Nov 2002; Ryan Phillips <rphillips@gentoo.org> vim-core-6.1-r3.ebuild :
+
+ Added Bret Towe's fixes to the ebuild. Fixes #10044
+
27 Oct 2002; Ryan Phillips <rphillips@gentoo.org> vim-core-6.1-r3.ebuild :
Added vim eclass support
diff --git a/app-editors/vim-core/vim-core-6.1-r3.ebuild b/app-editors/vim-core/vim-core-6.1-r3.ebuild
index 38cd234876c2..64088815919e 100644
--- a/app-editors/vim-core/vim-core-6.1-r3.ebuild
+++ b/app-editors/vim-core/vim-core-6.1-r3.ebuild
@@ -1,10 +1,10 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r3.ebuild,v 1.3 2002/10/29 05:43:30 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r3.ebuild,v 1.4 2002/11/08 03:45:57 rphillips Exp $
inherit vim
DESCRIPTION="vim, gvim and kvim shared files"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="dev-util/cscope
>=sys-libs/ncurses-5.2-r2
gpm? ( >=sys-libs/gpm-1.19.3 )
@@ -16,16 +16,8 @@ src_compile() {
local myconf
use nls && myconf="--enable-multibyte" || myconf="--disable-nls"
- use perl && myconf="$myconf --enable-perlinterp"
- use python && myconf="$myconf --enable-pythoninterp"
- use ruby && myconf="$myconf --enable-rubyinterp"
-
-# tclinterp is BROKEN. See note above DEPEND=
-# use tcltk && myconf="$myconf --enable-tclinterp"
-
-# Added back gpm for temporary will remove if necessary, I think that I have
-# fixed most of gpm so it should be fine.
- use gpm || myconf="$myconf --disable-gpm"
+ myconf="$myconf --disable-perlinterp --disable-pythoninterp --disable-rubyinterp"
+ myconf="$myconf --disable-gpm"
# This should fix a sandbox violation.
addwrite "${SSH_TTY}"
@@ -35,11 +27,11 @@ src_compile() {
#
./configure \
--prefix=/usr --mandir=/usr/share/man --host=$CHOST \
- --with-features=huge --with-cscope $myconf \
- --enable-gui=no \
+ --with-features=tiny $myconf \
+ --enable-gui=no --without-x \
|| die "vim configure failed"
# Parallel make does not work
- make || die "vim make failed"
+ make tools || die "vim make failed"
cd ${S}
rm src/vim
}
@@ -48,7 +40,7 @@ src_install() {
mkdir -p $D/usr/{bin,share/man/man1,share/vim}
cd src
make installruntime installhelplinks installmacros installtutor installtools install-languages install-icons DESTDIR=$D \
- BINDIR=/usr/bin MANDIR=/usr/share/man DATADIR=/usr/share
+ BINDIR=/usr/bin MANDIR=/usr/share/man DATADIR=/usr/share || die "make install failed"
# Docs
dodoc README*
cd $D/usr/share/doc/$PF
diff --git a/app-editors/vim/vim-6.1-r16.ebuild b/app-editors/vim/vim-6.1-r16.ebuild
index ea14dfd845b4..8f17f16f098b 100644
--- a/app-editors/vim/vim-6.1-r16.ebuild
+++ b/app-editors/vim/vim-6.1-r16.ebuild
@@ -1,11 +1,11 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r16.ebuild,v 1.2 2002/10/28 07:21:10 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r16.ebuild,v 1.3 2002/11/08 03:45:03 rphillips Exp $
inherit vim
DESCRIPTION="Vi IMproved!"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
DEPEND="app-editors/vim-core
dev-util/cscope
>=sys-libs/ncurses-5.2-r2