summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-24 22:17:48 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-24 22:17:48 +0000
commitaf9e7be38683be34724fd9aa92e868833a80df99 (patch)
tree88f69dee16528b547bec3a5d65fc49a0d0f4bb1a /app-editors
parentremove dep on module-init-tools and update. (diff)
downloadhistorical-af9e7be38683be34724fd9aa92e868833a80df99.tar.gz
historical-af9e7be38683be34724fd9aa92e868833a80df99.tar.bz2
historical-af9e7be38683be34724fd9aa92e868833a80df99.zip
fixes sandbox violation... unmask
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/vim-core-6.1-r4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-editors/vim-core/vim-core-6.1-r4.ebuild b/app-editors/vim-core/vim-core-6.1-r4.ebuild
index c0862b6f7167..d6748965c8ce 100644
--- a/app-editors/vim-core/vim-core-6.1-r4.ebuild
+++ b/app-editors/vim-core/vim-core-6.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r4.ebuild,v 1.2 2003/01/22 11:12:03 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r4.ebuild,v 1.3 2003/01/24 22:17:48 rphillips Exp $
VIMPATCH="vimpatch-1-300.tar.bz2"
inherit vim
@@ -23,7 +23,10 @@ src_compile() {
myconf="$myconf --disable-gpm"
# This should fix a sandbox violation.
- addwrite "${SSH_TTY}"
+ for file in /dev/pty/s*
+ do
+ addwrite $file
+ done
#
# Build a nogui version, this will install as /usr/bin/vim