summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-09-25 12:33:45 +0000
committerTorsten Veller <tove@gentoo.org>2005-09-25 12:33:45 +0000
commitbaedbed8c75d521051180667b1d47bc70710590d (patch)
tree6836e28ce531147f02c1c6ea348550d232aa28c1 /app-editors
parentApply whitespace checks from repoman to eclasses. (diff)
downloadhistorical-baedbed8c75d521051180667b1d47bc70710590d.tar.gz
historical-baedbed8c75d521051180667b1d47bc70710590d.tar.bz2
historical-baedbed8c75d521051180667b1d47bc70710590d.zip
Adapts changes in dev-libs/9libs.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wily/ChangeLog5
-rw-r--r--app-editors/wily/Manifest14
-rw-r--r--app-editors/wily/wily-1.0.ebuild28
3 files changed, 35 insertions, 12 deletions
diff --git a/app-editors/wily/ChangeLog b/app-editors/wily/ChangeLog
index 0cb63ac26d67..7545d17da68d 100644
--- a/app-editors/wily/ChangeLog
+++ b/app-editors/wily/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/wily
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/ChangeLog,v 1.8 2005/01/01 13:36:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/ChangeLog,v 1.9 2005/09/25 12:33:45 tove Exp $
+
+ 25 Sep 2005; Torsten Veller <tove@gentoo.org> wily-1.0.ebuild:
+ Adapts changes in dev-libs/9libs.
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> wily-1.0.ebuild:
Masked wily-1.0.ebuild stable for ppc
diff --git a/app-editors/wily/Manifest b/app-editors/wily/Manifest
index d868ef652d1e..5ca213c0cc76 100644
--- a/app-editors/wily/Manifest
+++ b/app-editors/wily/Manifest
@@ -1,3 +1,13 @@
-MD5 80d68b5e8d66dc5c1bc032da9340dda3 ChangeLog 958
-MD5 07433a78264291deb002fb149931fae9 wily-1.0.ebuild 713
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 ea3ce3a8aea241b4e11c8e19cd44452b ChangeLog 1054
+MD5 d5c65ec4f3cd4fb9d26b2b875ff7efb0 wily-1.0.ebuild 877
MD5 ac1d989779c3d7f524fb5470d2b48e1b files/digest-wily-1.0 62
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDNplAV3J2n04EauwRAtneAJ9TmSABcelGnruzhMCtjMIwHL4c+wCfZBP5
+PD+YBhkpZ62cEpe+X852EmE=
+=icgU
+-----END PGP SIGNATURE-----
diff --git a/app-editors/wily/wily-1.0.ebuild b/app-editors/wily/wily-1.0.ebuild
index b994065d8bc0..6d02be2179ca 100644
--- a/app-editors/wily/wily-1.0.ebuild
+++ b/app-editors/wily/wily-1.0.ebuild
@@ -1,25 +1,35 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/wily-1.0.ebuild,v 1.9 2005/01/01 13:36:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wily/wily-1.0.ebuild,v 1.10 2005/09/25 12:33:45 tove Exp $
+
+inherit toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor for programmers."
-HOMEPAGE="http://www.netlib.org/research/9libs/wily-9libs.README"
-SRC_URI="ftp://www.netlib.org/research/9libs/${P/1.0/9libs}.tar.gz"
+HOMEPAGE="http://www.netlib.org/research/9libs/"
+SRC_URI="ftp://www.netlib.org/research/9libs/${MY_P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="x86 ppc sparc"
+KEYWORDS="ppc sparc x86"
IUSE=""
DEPEND="virtual/x11
dev-libs/9libs"
-S="${WORKDIR}/${P/1.0/9libs}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf --includedir="/usr/include/9libs" || die "configure failed."
+ emake || die "make failed."
+}
src_install() {
- einstall docdir="${D}/usr/share/doc/${P}"
- dodoc INSTALL README
- insinto /usr/share/${P}
- doins ${S}/misc/*
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc README
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
}