summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-12-22 07:28:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-12-22 07:28:17 +0000
commita5ebb52d8b990110f49736035544108238eb258c (patch)
treeef939f627c5eb5c6cfa803bd7997c1e9e92b9e6e /app-emacs/md5
parent*** empty log message *** (diff)
downloadhistorical-a5ebb52d8b990110f49736035544108238eb258c.tar.gz
historical-a5ebb52d8b990110f49736035544108238eb258c.tar.bz2
historical-a5ebb52d8b990110f49736035544108238eb258c.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/md5')
-rw-r--r--app-emacs/md5/Manifest6
-rw-r--r--app-emacs/md5/files/90md5-gentoo.el4
-rw-r--r--app-emacs/md5/files/digest-md5-1.0-r11
-rw-r--r--app-emacs/md5/files/md5-1.0-gentoo.patch84
-rw-r--r--app-emacs/md5/md5-1.0-r1.ebuild21
-rw-r--r--app-emacs/md5/md5-1.0.ebuild4
6 files changed, 115 insertions, 5 deletions
diff --git a/app-emacs/md5/Manifest b/app-emacs/md5/Manifest
index c67734e275e5..b87a91e8e2bb 100644
--- a/app-emacs/md5/Manifest
+++ b/app-emacs/md5/Manifest
@@ -1,7 +1,7 @@
-MD5 e0dd7600c6735732c48b09b25514ed94 md5-1.0.ebuild 497
-MD5 31a37c9637d314b29c3575a6c6b0be42 ChangeLog 609
+MD5 d374b043109edde7c9df51188948bbe0 md5-1.0.ebuild 497
+MD5 5cde15f4e889fb266ad8361747193501 ChangeLog 609
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
-MD5 735fd05f98b87f8c4746695180425726 md5-1.0-r1.ebuild 608
+MD5 29d8bf82cc9c294e1f61bc1eebf7ac6f md5-1.0-r1.ebuild 611
MD5 5e841313e4359a577b07dada22d9a6a0 files/digest-md5-1.0 57
MD5 f5d336b3ee46486aace0dec744505e75 files/50md5-gentoo.el 76
MD5 f5d336b3ee46486aace0dec744505e75 files/90md5-gentoo.el 76
diff --git a/app-emacs/md5/files/90md5-gentoo.el b/app-emacs/md5/files/90md5-gentoo.el
new file mode 100644
index 000000000000..dc4da50f2280
--- /dev/null
+++ b/app-emacs/md5/files/90md5-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; site-lisp configuration for md5
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/md5/files/digest-md5-1.0-r1 b/app-emacs/md5/files/digest-md5-1.0-r1
new file mode 100644
index 000000000000..57785d7633ba
--- /dev/null
+++ b/app-emacs/md5/files/digest-md5-1.0-r1
@@ -0,0 +1 @@
+MD5 a1439b60e379ebfe279b4e32ebd06b37 md5-1.0.tar.gz 5736
diff --git a/app-emacs/md5/files/md5-1.0-gentoo.patch b/app-emacs/md5/files/md5-1.0-gentoo.patch
new file mode 100644
index 000000000000..467d54ef2af3
--- /dev/null
+++ b/app-emacs/md5/files/md5-1.0-gentoo.patch
@@ -0,0 +1,84 @@
+diff -ur md5-1.0/md5.el md5-1.0.orig/md5.el
+--- md5-1.0/md5.el 2003-11-21 23:59:30.000000000 -0600
++++ md5-1.0.orig/md5.el 2003-12-21 23:59:40.839985880 -0600
+@@ -368,39 +368,44 @@
+ ;;; Here begins the merger with the XEmacs API and the md5.el from the URL
+ ;;; package. Courtesy wmperry@cs.indiana.edu
+ ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+-(defun md5 (object &optional start end)
+- "Return the MD5 (a secure message digest algorithm) of an object.
+-OBJECT is either a string or a buffer.
+-Optional arguments START and END denote buffer positions for computing the
+-hash of a portion of OBJECT."
+- (let ((buffer nil))
+- (unwind-protect
+- (save-excursion
+- (setq buffer (generate-new-buffer " *md5-work*"))
+- (set-buffer buffer)
+- (cond
+- ((bufferp object)
+- (insert-buffer-substring object start end))
+- ((stringp object)
+- (insert (if (or start end)
+- (substring object start end)
+- object)))
+- (t nil))
+- (prog1
+- (if (<= (point-max) md5-maximum-internal-length)
+- (mapconcat
+- (function (lambda (node) (format "%02x" node)))
+- (md5-encode (buffer-string))
+- "")
+- (call-process-region (point-min) (point-max)
+- shell-file-name
+- t buffer nil
+- shell-command-switch md5-program)
+- ;; MD5 digest is 32 chars long
+- ;; mddriver adds a newline to make neaten output for tty
+- ;; viewing, make sure we leave it behind.
+- (buffer-substring (point-min) (+ (point-min) 32)))
+- (kill-buffer buffer)))
+- (and buffer (buffer-name buffer) (kill-buffer buffer) nil))))
+
+-(provide 'md5)
++;; Emacs 21.3 already defines this function.
++
++;; (defun md5 (object &optional start end)
++;; "Return the MD5 (a secure message digest algorithm) of an object.
++;; OBJECT is either a string or a buffer.
++;; Optional arguments START and END denote buffer positions for computing the
++;; hash of a portion of OBJECT."
++;; (let ((buffer nil))
++;; (unwind-protect
++;; (save-excursion
++;; (setq buffer (generate-new-buffer " *md5-work*"))
++;; (set-buffer buffer)
++;; (cond
++;; ((bufferp object)
++;; (insert-buffer-substring object start end))
++;; ((stringp object)
++;; (insert (if (or start end)
++;; (substring object start end)
++;; object)))
++;; (t nil))
++;; (prog1
++;; (if (<= (point-max) md5-maximum-internal-length)
++;; (mapconcat
++;; (function (lambda (node) (format "%02x" node)))
++;; (md5-encode (buffer-string))
++;; "")
++;; (call-process-region (point-min) (point-max)
++;; shell-file-name
++;; t buffer nil
++;; shell-command-switch md5-program)
++;; ;; MD5 digest is 32 chars long
++;; ;; mddriver adds a newline to make neaten output for tty
++;; ;; viewing, make sure we leave it behind.
++;; (buffer-substring (point-min) (+ (point-min) 32)))
++;; (kill-buffer buffer)))
++;; (and buffer (buffer-name buffer) (kill-buffer buffer) nil))))
++
++;; An md5 module is already provided by FLIM.
++
++(provide 'md5-digest)
+Only in md5-1.0.orig: md5.el~
diff --git a/app-emacs/md5/md5-1.0-r1.ebuild b/app-emacs/md5/md5-1.0-r1.ebuild
new file mode 100644
index 000000000000..9c972d720560
--- /dev/null
+++ b/app-emacs/md5/md5-1.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/md5/md5-1.0-r1.ebuild,v 1.1 2003/12/22 07:28:10 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp implementation of the MD5 algorithm."
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/WikifiedEmacsLispList"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/emacs"
+
+SITEFILE=90md5-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gentoo.patch || die
+ mv ${S}/md5.el ${S}/md5-digest.el
+}
diff --git a/app-emacs/md5/md5-1.0.ebuild b/app-emacs/md5/md5-1.0.ebuild
index f2fc2eecc7f0..09cb116ce33a 100644
--- a/app-emacs/md5/md5-1.0.ebuild
+++ b/app-emacs/md5/md5-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/md5/md5-1.0.ebuild,v 1.1 2003/11/22 06:23:21 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/md5/md5-1.0.ebuild,v 1.2 2003/12/22 07:28:10 mkennedy Exp $
inherit elisp
@@ -12,4 +12,4 @@ SLOT="0"
KEYWORDS="x86"
DEPEND="virtual/emacs"
-SITEFILE=50md5-gentoo.el
+SITEFILE=90md5-gentoo.el