summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/psql
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/psql')
-rw-r--r--app-emacs/psql/ChangeLog11
-rw-r--r--app-emacs/psql/files/50psql-gentoo.el7
-rw-r--r--app-emacs/psql/files/digest-psql-1.101
-rw-r--r--app-emacs/psql/psql-1.10.ebuild39
4 files changed, 58 insertions, 0 deletions
diff --git a/app-emacs/psql/ChangeLog b/app-emacs/psql/ChangeLog
new file mode 100644
index 000000000000..775d008e7f9e
--- /dev/null
+++ b/app-emacs/psql/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/psql
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/psql/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*psql-1.10 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ psql-1.10.ebuild, files/50psql-gentoo.el,
+ files/digest-psql-1.10 :
+
+ Initial import.
diff --git a/app-emacs/psql/files/50psql-gentoo.el b/app-emacs/psql/files/50psql-gentoo.el
new file mode 100644
index 000000000000..15c3407ea117
--- /dev/null
+++ b/app-emacs/psql/files/50psql-gentoo.el
@@ -0,0 +1,7 @@
+
+;;; psql site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(autoload 'psql-mode "psql-mode" "Mode for editing postgress sql." t)
+(autoload 'psql-run "psql-mode" "Mode for editing postgress sql." t)
+(add-to-list 'auto-mode-alist '("\\.p?sql$" . psql-mode ))
diff --git a/app-emacs/psql/files/digest-psql-1.10 b/app-emacs/psql/files/digest-psql-1.10
new file mode 100644
index 000000000000..76e0e57b0c8d
--- /dev/null
+++ b/app-emacs/psql/files/digest-psql-1.10
@@ -0,0 +1 @@
+MD5 12c08f3e4b1cb4541bf72675da8d3042 psql-1.10.tar.bz2 4745
diff --git a/app-emacs/psql/psql-1.10.ebuild b/app-emacs/psql/psql-1.10.ebuild
new file mode 100644
index 000000000000..1d368cd3ec4f
--- /dev/null
+++ b/app-emacs/psql/psql-1.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/psql/psql-1.10.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing PostgreSQL SQL"
+HOMEPAGE="http://www.hgsc.bcm.tmc.edu/~harley/elisp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ dev-db/postgresql"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50psql-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/psql.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}