summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-08 09:25:10 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-08 09:25:10 +0000
commit6cb8052c9eab467dc537b0f619dee58b5b1f2e8c (patch)
tree2ed85c609956078128d7933a5da6d300b64c5c04 /app-emacs/riece/riece-1.0.7b.ebuild
parentPackage-Manager: portage-2.0.51-r15 (diff)
downloadhistorical-6cb8052c9eab467dc537b0f619dee58b5b1f2e8c.tar.gz
historical-6cb8052c9eab467dc537b0f619dee58b5b1f2e8c.tar.bz2
historical-6cb8052c9eab467dc537b0f619dee58b5b1f2e8c.zip
Version bumped. Marked 1.0.6 stable on x86, alpha, ppc and ppc-macos. Removed 1.0.4 from CVS.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-emacs/riece/riece-1.0.7b.ebuild')
-rw-r--r--app-emacs/riece/riece-1.0.7b.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/riece/riece-1.0.7b.ebuild b/app-emacs/riece/riece-1.0.7b.ebuild
new file mode 100644
index 000000000000..a533c1da2f0e
--- /dev/null
+++ b/app-emacs/riece/riece-1.0.7b.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/riece/riece-1.0.7b.ebuild,v 1.1 2005/02/08 09:25:10 usata Exp $
+
+inherit elisp
+
+IUSE=""
+S="${WORKDIR}/${P/b/}"
+
+DESCRIPTION="Riece is a redesign of Liece IRC client"
+HOMEPAGE="http://www.nongnu.org/riece/"
+SRC_URI="http://savannah.nongnu.org/download/riece/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~ppc64 ~amd64 ~ppc-macos"
+
+SITEFILE=50riece-gentoo.el
+
+src_compile() {
+
+ econf --with-lispdir=${SITELISP} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ einstall lispdir=${D}/${SITELISP} || die "einstall failed"
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}