summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-11-02 17:00:13 +0000
committerUlrich Müller <ulm@gentoo.org>2012-11-02 17:00:13 +0000
commita9cfa4fc2d9ed4bf3ba62ab4e39f80e0454e1999 (patch)
treebe0eb4885e285e84d397995ec4f617fb677369cf /app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
parentdev-tcltk/tkXwin: Drop old (diff)
downloadhistorical-a9cfa4fc2d9ed4bf3ba62ab4e39f80e0454e1999.tar.gz
historical-a9cfa4fc2d9ed4bf3ba62ab4e39f80e0454e1999.tar.bz2
historical-a9cfa4fc2d9ed4bf3ba62ab4e39f80e0454e1999.zip
Fix site initialisation, bug 440882.
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0xE7BE08CA7DC6EA25
Diffstat (limited to 'app-emacs/sml-mode/sml-mode-6.1-r1.ebuild')
-rw-r--r--app-emacs/sml-mode/sml-mode-6.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
new file mode 100644
index 000000000000..d44c39ab3495
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild,v 1.1 2012/11/02 17:00:09 ulm Exp $
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://bzr.sv.gnu.org/r/emacs/elpa
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/xz-utils"
+
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+}