summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-02 08:35:49 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-02 08:35:49 +0000
commitf4f2d15bae2587a8d2bc01b61685f99bb7feaede (patch)
treeae815334d938671e6c3fd5099aea51619149f65a /app-emacs/vm/vm-7.19.ebuild
parentEnable autoconfig by default for mips systems, since some packages don't corr... (diff)
downloadhistorical-f4f2d15bae2587a8d2bc01b61685f99bb7feaede.tar.gz
historical-f4f2d15bae2587a8d2bc01b61685f99bb7feaede.tar.bz2
historical-f4f2d15bae2587a8d2bc01b61685f99bb7feaede.zip
Version bumped and corrected LICENSE (GPL-2 to GPL-1). Thanks to Ulrich Mueller <ulm@kph.uni-mainz.de>. This closes bug #66017.
Diffstat (limited to 'app-emacs/vm/vm-7.19.ebuild')
-rw-r--r--app-emacs/vm/vm-7.19.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/vm/vm-7.19.ebuild b/app-emacs/vm/vm-7.19.ebuild
new file mode 100644
index 000000000000..a3889b5e1561
--- /dev/null
+++ b/app-emacs/vm/vm-7.19.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.19.ebuild,v 1.1 2004/10/02 08:35:49 usata Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="An emacs major mode for reading and writing e-mail with support for GPG and MIME."
+HOMEPAGE="http://www.wonderworks.com/vm/"
+SRC_URI="ftp://ftp.uni-mainz.de/pub/software/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.uu.net/networking/mail/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/emacs"
+
+SITEFILE=50vm-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/vm-direntry-fix-gentoo.patch
+}
+
+src_compile() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ all || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ INFODIR=${D}/usr/share/info \
+ LISPDIR=${D}/${SITELISP}/vm \
+ PIXMAPDIR=${D}/${SITELISP}/etc/${PN} \
+ install || die
+ elisp-install ${PN} *.el
+ elisp-site-file-install ${FILESDIR}/50vm-gentoo.el
+ dodoc README
+}