summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-05-11 17:29:26 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-05-11 17:29:26 +0000
commit7ab832b210937610c2642f076f3c7edfc68f7110 (patch)
tree0a248b34d90801fdc4e651571db8104499116116 /app-emacs
parentVersion bump. (diff)
downloadhistorical-7ab832b210937610c2642f076f3c7edfc68f7110.tar.gz
historical-7ab832b210937610c2642f076f3c7edfc68f7110.tar.bz2
historical-7ab832b210937610c2642f076f3c7edfc68f7110.zip
Version bump.
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yc/ChangeLog9
-rw-r--r--app-emacs/yc/files/digest-yc-3.5.71
-rw-r--r--app-emacs/yc/files/sample.hosts.canna2
-rw-r--r--app-emacs/yc/yc-3.5.7.ebuild50
4 files changed, 60 insertions, 2 deletions
diff --git a/app-emacs/yc/ChangeLog b/app-emacs/yc/ChangeLog
index 33d3bff773db..1273102ed94b 100644
--- a/app-emacs/yc/ChangeLog
+++ b/app-emacs/yc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/yc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.5 2003/03/31 04:50:09 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/ChangeLog,v 1.6 2003/05/11 17:29:26 nakano Exp $
+
+*yc-3.5.7 (11 May 2003)
+
+ 11 May 2003; Masatomo Nakano <nakano@gentoo.org> ChangeLog, yc-3.5.7.ebuild,
+ files/sample.hosts.canna:
+
+ Version bump.
*yc-3.5.2 (31 Mar 2003)
diff --git a/app-emacs/yc/files/digest-yc-3.5.7 b/app-emacs/yc/files/digest-yc-3.5.7
new file mode 100644
index 000000000000..06bc50ffc8df
--- /dev/null
+++ b/app-emacs/yc/files/digest-yc-3.5.7
@@ -0,0 +1 @@
+MD5 6c5f0e42698f0c54b08c76b8bbc28370 yc.el-3.5.7.gz 32514
diff --git a/app-emacs/yc/files/sample.hosts.canna b/app-emacs/yc/files/sample.hosts.canna
index 70523ea54f9a..960d75f5266c 100644
--- a/app-emacs/yc/files/sample.hosts.canna
+++ b/app-emacs/yc/files/sample.hosts.canna
@@ -1,2 +1,2 @@
localhost
-unix \ No newline at end of file
+unix
diff --git a/app-emacs/yc/yc-3.5.7.ebuild b/app-emacs/yc/yc-3.5.7.ebuild
new file mode 100644
index 000000000000..40e2d6598765
--- /dev/null
+++ b/app-emacs/yc/yc-3.5.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/yc/yc-3.5.7.ebuild,v 1.1 2003/05/11 17:29:26 nakano Exp $
+
+inherit elisp
+
+IUSE=""
+
+MY_P=yc.el-${PV}
+DESCRIPTION="YC - Yet another Canna client on Emacsen."
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${MY_P}.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ >=app-i18n/canna-3.6"
+
+S="${WORKDIR}/${P}"
+SITEFILE="50yc-gentoo.el"
+
+src_unpack() {
+ mkdir -p ${S}
+ gzip -dc ${DISTDIR}/${MY_P}.gz > ${S}/yc.el
+}
+
+src_compile() {
+ emacs -batch -eval '(byte-compile-file "yc.el")'
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+
+ dodoc ${FILESDIR}/sample*
+}
+
+pkg_postinst() {
+ einfo "Please modify as following in /etc/conf.d/canna."
+ einfo "\n\t CANNASERVER_OPTS=\"-inet\"\n"
+ einfo "And create /etc/hosts.canna."
+ einfo "(sample is /usr/share/doc/${P}/sample.hosts.canna.gz)"
+ einfo "And see /usr/share/doc/${P}/sample.dot.emacs.gz."
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}