summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-01-25 20:26:36 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-01-25 20:26:36 +0000
commit1dabef5acb7a2f50da538c1e30f32a78bf0c6992 (patch)
tree09ee858ed9022257f6775f3d88e91ac70d2dce16 /app-emulation/bochs/bochs-2.2.5.ebuild
parentFix USE flag check. (diff)
downloadhistorical-1dabef5acb7a2f50da538c1e30f32a78bf0c6992.tar.gz
historical-1dabef5acb7a2f50da538c1e30f32a78bf0c6992.tar.bz2
historical-1dabef5acb7a2f50da538c1e30f32a78bf0c6992.zip
New version, gcc-4.1 support, modular X support
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-emulation/bochs/bochs-2.2.5.ebuild')
-rw-r--r--app-emulation/bochs/bochs-2.2.5.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/app-emulation/bochs/bochs-2.2.5.ebuild b/app-emulation/bochs/bochs-2.2.5.ebuild
new file mode 100644
index 000000000000..ebc5ec263984
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.2.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.2.5.ebuild,v 1.1 2006/01/25 20:26:36 lu_zero Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ppc ~sparc ~x86"
+IUSE="debugger readline sdl wxwindows"
+
+RDEPEND="virtual/libc
+ || ( virtual/x11
+ ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm ) )
+ sdl? ( media-libs/libsdl )
+ wxwindows? ( >=x11-libs/wxGTK-2.6 )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ || ( virtual/x11
+ x11-proto/xproto )
+ >=sys-apps/sed-4
+ >=app-text/opensp-1.5"
+
+src_unpack() {
+# unpack ${A}
+ unpack ${P}.tar.gz
+ cd ${S}
+# -e 's:MAN_PAGE_1_LIST=bochs bximage bochs-dlx:MAN_PAGE_1_LIST=bochs bximage:'
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
+ die "sed Makefile.in failed"
+
+# Make it use the correct path to gtk-2
+ sed -i -e "s:/opt/gnome:/usr:" configure
+# Fix some bad coding for gcc-4.1 compliance
+ sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
+}
+
+src_compile() {
+ export WX_GTK_VER=2.6
+
+ use wxwindows && \
+ need-wxwidgets gtk2
+
+ [ "$ARCH" == "x86" ] \
+ && myconf="--enable-idle-hack --enable-fast-function-calls"
+ myconf="${myconf} `use_with sdl`"
+ myconf="${myconf} `use_enable readline`"
+ use wxwindows && \
+ myconf="${myconf} --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-wx"
+ use debugger && \
+ myconf="$myconf --enable-debugger --enable-disasm \
+ --enable-x86-debugger --enable-iodebug"
+
+ ./configure \
+ --enable-fpu --enable-cdrom \
+ --enable-usb --enable-pci \
+ --enable-mmx --enable-sse=2 --enable-3dnow \
+ --enable-cpu-level=6 --enable-vbe \
+ --enable-repeat-speedups --enable-guest2host-tlb \
+ --enable-plugins \
+ --enable-ignore-bad-msr \
+ --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} \
+ --with-x11 ${myconf} || die "configure failed"
+
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install unpack_dlx || die "make install failed"
+ #workaround
+ make prefix=${D}/usr install_dlx
+
+ dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
+}