summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 02:39:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 02:39:02 +0000
commit2764d43a113b9f469155f5f34b4398f64562a5ff (patch)
treea558156b3fb30bf968e6bf1904edbff16891b763 /app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild
parentcrossover office (diff)
downloadhistorical-2764d43a113b9f469155f5f34b4398f64562a5ff.tar.gz
historical-2764d43a113b9f469155f5f34b4398f64562a5ff.tar.bz2
historical-2764d43a113b9f469155f5f34b4398f64562a5ff.zip
initial import #66843
Diffstat (limited to 'app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild')
-rw-r--r--app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild b/app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild
new file mode 100644
index 000000000000..880a75fa4dcc
--- /dev/null
+++ b/app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-bin/crossover-office-bin-3.0.1.ebuild,v 1.1 2004/10/31 02:39:02 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-standard-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+RDEPEND="virtual/x11
+ virtual/libc"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}