summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-13 22:51:30 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-13 22:51:30 +0000
commit9d0d0ada296a2aab298ff53f77b01a9a1fec4e51 (patch)
tree31ffd823c14bb8256918635f3df83675f2e58a08 /app-emulation/freesci
parentMake php-5.0_beta1 work.. (diff)
downloadhistorical-9d0d0ada296a2aab298ff53f77b01a9a1fec4e51.tar.gz
historical-9d0d0ada296a2aab298ff53f77b01a9a1fec4e51.tar.bz2
historical-9d0d0ada296a2aab298ff53f77b01a9a1fec4e51.zip
xft bug #24398
Diffstat (limited to 'app-emulation/freesci')
-rw-r--r--app-emulation/freesci/ChangeLog5
-rw-r--r--app-emulation/freesci/Manifest4
-rw-r--r--app-emulation/freesci/freesci-0.3.4a.ebuild41
3 files changed, 30 insertions, 20 deletions
diff --git a/app-emulation/freesci/ChangeLog b/app-emulation/freesci/ChangeLog
index ceb8052721a4..aed4771a0658 100644
--- a/app-emulation/freesci/ChangeLog
+++ b/app-emulation/freesci/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/freesci
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/ChangeLog,v 1.6 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/ChangeLog,v 1.7 2003/07/13 22:51:24 vapier Exp $
*freescsi-0.4.3a (12 May 2003)
+ 13 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a lot of optional support and fixed XFT bug #24398.
+
12 May 2003; Daniel Ahlberg <aliz@gentoo.org> :
Version bump.
diff --git a/app-emulation/freesci/Manifest b/app-emulation/freesci/Manifest
index e84a06fae66b..e4758fab5229 100644
--- a/app-emulation/freesci/Manifest
+++ b/app-emulation/freesci/Manifest
@@ -1,5 +1,5 @@
MD5 ddaa777cfa9c98a98580e5c80594a400 files/digest-freesci-0.3.3 66
MD5 f4396d74a3074af057c248aa3785e894 files/digest-freesci-0.3.4a 67
MD5 d2f95f72a9d6aebeeab9e2d940f8ff9b freesci-0.3.3.ebuild 799
-MD5 236b068a0cf4178688b98e36176fda1e ChangeLog 769
-MD5 d53e01413a4d8f5f2281f6927676adf2 freesci-0.3.4a.ebuild 795
+MD5 7c797f66f026b498834bb75b68e29da5 ChangeLog 884
+MD5 dbc156cb9b7f7062b3de5f411e76f00d freesci-0.3.4a.ebuild 1143
diff --git a/app-emulation/freesci/freesci-0.3.4a.ebuild b/app-emulation/freesci/freesci-0.3.4a.ebuild
index 8b9128335434..d20674daf22e 100644
--- a/app-emulation/freesci/freesci-0.3.4a.ebuild
+++ b/app-emulation/freesci/freesci-0.3.4a.ebuild
@@ -1,33 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/freesci-0.3.4a.ebuild,v 1.2 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/freesci-0.3.4a.ebuild,v 1.3 2003/07/13 22:51:24 vapier Exp $
+
+inherit games flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Sierra script interpreter for your old Sierra adventures"
-SRC_URI="http://savannah.nongnu.org/download/freesci/stable.pkg/${PV}/${P}.tar.bz2"
+SRC_URI="http://savannah.nongnu.org/download/freesci/stable.pkg/${PV}/${P}.tar.bz2
+ http://teksolv.de/~jameson/${P}.tar.bz2"
HOMEPAGE="http://freesci.linuxgames.com/"
+
LICENSE="GPL-2"
KEYWORDS="x86"
SLOT="0"
-IUSE=""
+IUSE="X ggi directfb alsa sdl ncurses"
-DEPEND="virtual/x11"
+DEPEND="X? ( virtual/x11 =media-libs/freetype-2* )
+ ggi? ( media-libs/libggi )
+ directfb? ( dev-libs/DirectFB )
+ alsa? ( >=media-libs/alsa-lib-0.5.0 )
+ sdl? ( >=media-libs/libsdl-1.1.8 )
+ ncurses? ( sys-libs/ncurses )"
src_compile() {
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man || die "./configure failed"
-
+ use X && append-flags -I/usr/include/freetype2
+ egamesconf \
+ `use_with X x` \
+ `use_with sdl` \
+ `use_with directfb` \
+ `use_with ggi` \
+ `use_with alsa` \
+ || die
emake || die
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
-
- dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README.Unix THANKS TODO
-
+ dodoc AUTHORS ChangeLog INSTALL NEWS README README.Unix THANKS TODO
+ prepgamesdirs
}