summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-03-12 19:11:19 +0000
committerLance Albertson <ramereth@gentoo.org>2011-03-12 19:11:19 +0000
commit6f66f021da61b5ffb87bf3b86d6e0be3f7fba20c (patch)
tree46475306d036ec8ef0b3597603c223fb751a5966 /app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
parentalpha/arm/ia64/sparc stable wrt #353436 (diff)
downloadhistorical-6f66f021da61b5ffb87bf3b86d6e0be3f7fba20c.tar.gz
historical-6f66f021da61b5ffb87bf3b86d6e0be3f7fba20c.tar.bz2
historical-6f66f021da61b5ffb87bf3b86d6e0be3f7fba20c.zip
version bump
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild')
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
new file mode 100644
index 000000000000..819c0a998e9e
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild,v 1.1 2011/03/12 19:11:19 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network
+ dev-haskell/parallel"
+RDEPEND="${DEPEND}
+ !<app-emulation/ganeti-2.4"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+ # Workaround to skip pandoc
+ sed -i -e "s:) man:):" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman man/*.1
+ dodoc README NEWS AUTHORS
+ use doc && dohtml -r apidoc/*
+}