summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-12 18:27:27 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-12 18:27:27 +0000
commit72703429f966475c8b4f0116067d32b2149271a2 (patch)
treeee381a43a43abd8ebe2ec2d03a38cf2956aa7408 /app-emulation/hercules/hercules-3.00.ebuild
parentbump (diff)
downloadhistorical-72703429f966475c8b4f0116067d32b2149271a2.tar.gz
historical-72703429f966475c8b4f0116067d32b2149271a2.tar.bz2
historical-72703429f966475c8b4f0116067d32b2149271a2.zip
bump
Diffstat (limited to 'app-emulation/hercules/hercules-3.00.ebuild')
-rw-r--r--app-emulation/hercules/hercules-3.00.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/hercules/hercules-3.00.ebuild b/app-emulation/hercules/hercules-3.00.ebuild
new file mode 100644
index 000000000000..0f89c4d68bbd
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.00.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.00.ebuild,v 1.1 2003/10/12 18:27:22 lanius Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
+HOMEPAGE="http://www.conmicro.cx/hercules/"
+LICENSE="QPL-1.0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-apps/bzip2"
+
+src_compile() {
+ local mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+
+ econf \
+ --enable-optimization="${mycflags}" \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ --enable-multi-cpu=7 \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.COMMADPT README.CVS README.ECPSVM README.HDL
+ dodoc README.NETWORKING README.OSX README.TAPE
+ dodoc RELEASE.NOTES CHANGES
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Hercules System/370, ESA/390 and zArchitecture Mainframe"
+ einfo "Emulator has been installed. Some useful utility files have"
+ einfo "been placed in /usr/share/hercules. For detailed configuration"
+ einfo "and operating instructions, see http://www.conmicro.cx/hercules"
+ einfo
+ einfo "In order to use Hercules you will need a guest operating"
+ einfo "system. There are several flavours of 'Linux for S/390' and"
+ einfo "'Linux for zSeries' available, or if you want that 'Big Iron'"
+ einfo "feel, you can download several real mainframe operating systems"
+ einfo "such as OS/360, DOS/VS, MVS, or VM370 from http://www.cbttape.org"
+ einfo
+ einfo "Hercules is also capable of runing OS/390, z/OS, and z/VM with an"
+ einfo "appropriate liscense."
+ einfo
+}