summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-07-12 13:19:05 +0000
committerMark Guertin <gerk@gentoo.org>2002-07-12 13:19:05 +0000
commit410eb77681a0c46b27744019b4b82a3328cdc1ea (patch)
tree441212a54edb10f4be800f771a0309583e58bab4 /app-emulation/mol
parentversion bump (diff)
downloadhistorical-410eb77681a0c46b27744019b4b82a3328cdc1ea.tar.gz
historical-410eb77681a0c46b27744019b4b82a3328cdc1ea.tar.bz2
historical-410eb77681a0c46b27744019b4b82a3328cdc1ea.zip
added new mol build
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog9
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.641
-rw-r--r--app-emulation/mol/mol-0.9.63.ebuild3
-rw-r--r--app-emulation/mol/mol-0.9.64.ebuild43
4 files changed, 54 insertions, 2 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 4a7ea478b986..4ae3f2b62677 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/mol
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.3 2002/06/22 00:24:43 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.4 2002/07/12 13:19:05 gerk Exp $
+
+*mol-0.9.64 (12 July 2002)
+
+ 12 July 2002; Gerk (gerk@gentoo.org)
+
+ Added 0.9.64, simple bump and moved to
+ emake instead of make
*mol-0.9.63 (5 May 2002)
diff --git a/app-emulation/mol/files/digest-mol-0.9.64 b/app-emulation/mol/files/digest-mol-0.9.64
new file mode 100644
index 000000000000..c8aafff9cbf1
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.64
@@ -0,0 +1 @@
+MD5 558fe59494edbcd9f26f804128925871 mol-0.9.64.tgz 1186426
diff --git a/app-emulation/mol/mol-0.9.63.ebuild b/app-emulation/mol/mol-0.9.63.ebuild
index df52cb45730c..1135e424aadd 100644
--- a/app-emulation/mol/mol-0.9.63.ebuild
+++ b/app-emulation/mol/mol-0.9.63.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.63.ebuild,v 1.5 2002/06/22 00:24:43 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.63.ebuild,v 1.6 2002/07/12 13:19:05 gerk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
@@ -11,6 +11,7 @@ DEPEND="virtual/glibc"
RDEPEND=""
SLOT="0"
LICENSE="GPL"
+KEYWORDS="ppc -x86 -sparc"
pkg_setup() {
if [ ${ARCH} != "ppc" ] ; then
diff --git a/app-emulation/mol/mol-0.9.64.ebuild b/app-emulation/mol/mol-0.9.64.ebuild
new file mode 100644
index 000000000000..c434768c3942
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.64.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.64.ebuild,v 1.1 2002/07/12 13:19:05 gerk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
+SRC_URI="ftp://ftp.nada.kth.se/pub/home/f95-sry/Public/mac-on-linux/${P}.tgz"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="ppc -x86 -sparc"
+
+pkg_setup() {
+ if [ ${ARCH} != "ppc" ] ; then
+ eerror "Sorry, this is a PPC only package."
+ die "Sorry, this as a PPC only pacakge."
+ fi
+}
+
+src_compile() {
+
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ emake || die "Failed to compile MOL"
+}
+
+src_install() {
+
+ emake DESTDIR=${D} install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol"
+ einfo "You might want to configure video modes first with molvconfig"
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+}