summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-16 05:04:45 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-16 05:04:45 +0000
commit0937a97255d7bf1f532c6f3a030659834a04222f (patch)
tree2bbcdf02fe5c6aa452224dea761863d9714b88ae /app-emulation/ski/ski-1.3.2.ebuild
parentRevision bump, add patches for bugs 412053 and 381873. Also don't use gcc dir... (diff)
downloadhistorical-0937a97255d7bf1f532c6f3a030659834a04222f.tar.gz
historical-0937a97255d7bf1f532c6f3a030659834a04222f.tar.bz2
historical-0937a97255d7bf1f532c6f3a030659834a04222f.zip
Initial ebuild by Dennis Schridde #376411.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/ski/ski-1.3.2.ebuild')
-rw-r--r--app-emulation/ski/ski-1.3.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/ski/ski-1.3.2.ebuild b/app-emulation/ski/ski-1.3.2.ebuild
new file mode 100644
index 000000000000..22367434810b
--- /dev/null
+++ b/app-emulation/ski/ski-1.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ski/ski-1.3.2.ebuild,v 1.1 2012/04/16 05:04:45 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="ia64 instruction set simulator"
+HOMEPAGE="http://ski.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk motif"
+
+# We use ltdl from libtool at runtime.
+RDEPEND="sys-devel/libtool
+ || ( dev-libs/elfutils dev-libs/libelf )
+ sys-libs/ncurses
+ gtk? ( x11-libs/gtk+:2 )
+ motif? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ dev-util/gperf"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-syscall-linux-includes.patch \
+ "${FILESDIR}"/${P}-remove-hayes.patch \
+ "${FILESDIR}"/${P}-no-local-ltdl.patch
+
+ rm -rf libltdl src/ltdl.[ch] macros/ltdl.m4
+
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-included-ltdl \
+ $(use_enable gtk) \
+ $(use_enable motif x11)
+}