summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Marlowe <mattm@gentoo.org>2006-02-11 21:27:28 +0000
committerMatthew Marlowe <mattm@gentoo.org>2006-02-11 21:27:28 +0000
commit6b2dc64efa54c8f7ba82c8ad58a48a56bb913133 (patch)
treebd9e4716302a1f9dea788bef95a25c2d777883fb /app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild
parentVirtuals for some perl-core deps (diff)
downloadhistorical-6b2dc64efa54c8f7ba82c8ad58a48a56bb913133.tar.gz
historical-6b2dc64efa54c8f7ba82c8ad58a48a56bb913133.tar.bz2
historical-6b2dc64efa54c8f7ba82c8ad58a48a56bb913133.zip
initial commit of the new gsx console ebuild.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild')
-rw-r--r--app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild b/app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild
new file mode 100644
index 000000000000..fee5c32052f5
--- /dev/null
+++ b/app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-gsx-console/vmware-gsx-console-3.2.0.14497.ebuild,v 1.1 2006/02/11 21:27:28 mattm Exp $
+MY_PN="VMware-gsx-server-linux-client"
+MY_PV=${PV%.*}-${PV##*.}
+MY_P="${MY_PN}-${MY_PV}"
+FN="${MY_P}.zip"
+S="${WORKDIR}/vmware-console-distrib"
+
+DESCRIPTION="VMware GSX Console for Linux"
+HOMEPAGE="http://www.vmware.com/"
+SRC_URI="${FN}"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="fetch nostrip"
+
+DEPEND="virtual/libc"
+
+RDEPEND="|| ( ( x11-libs/gtk+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXpm
+ x11-libs/libXtst
+ x11-libs/libX11 )
+ virtual/x11 )
+ sys-libs/zlib"
+
+pkg_nofetch() {
+ einfo "Please obtain ${FN} and place it in ${DISTDIR}"
+}
+
+src_install () {
+ # Set up config database
+ echo 'libdir = "/opt/vmware-console/lib"' >etc/config
+ cat >etc/locations <<EOF
+file /opt/vmware-console/etc/locations
+answer BINDIR /opt/vmware-console/bin
+answer LIBDIR /opt/vmware-console/lib
+answer DOCDIR /usr/share/doc/${P}
+answer MANDIR /usr/share/man
+file /opt/vmware-console/etc/not_configured 1085493247
+file /opt/vmware-console/etc/config 1085493247
+EOF
+
+ # Install docs and man pages
+ dodoc doc/*
+ find man -name \*.\?.gz | xargs doman
+ dohtml -r lib/help lib/help-guestinstall lib/help-manual
+ wd=`pwd`
+ cd ${D}/usr/share/doc/${P}/html
+ for i in help help-guestinstall help-manual; do
+ cd $i
+ if use esx; then
+ for j in esx/*; do
+ ln -s $j
+ done
+ else
+ for j in gsx/*; do
+ ln -s $j
+ done
+ fi
+ cd ..
+ done
+ cd ${wd}
+
+ # Install everything else
+ into /opt/vmware-console
+ dobin bin/*
+ dodir /opt/vmware-console/etc
+ cp -dr etc/* ${D}/opt/vmware-console/etc/
+ dodir /etc
+ dosym /opt/vmware-console/etc /etc/vmware-console
+
+ # Setup environment to include our bin directory in the PATH
+ insinto /etc/env.d
+ doins ${FILESDIR}/99vmware-console
+
+ # We already installed the HTML docs, so we can use symlinks
+ dodir /opt/vmware-console/lib
+ rm -rf lib/help lib/help-guestinstall lib/help-manual
+ cp -dr lib/* ${D}/opt/vmware-console/lib/
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help-guestinstall
+ dosym /usr/share/doc/${P}/html/help /opt/vmware-console/lib/help-manual
+}
+