summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-23 16:45:20 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-23 16:45:20 +0000
commit01fce1c0bd6758c80357f81aadd405871c23ebb2 (patch)
tree29369b5b277cc35b3f5837aa66afe54f647add57 /app-emulation/wine/wine-1.5.10.ebuild
parentRemoving old ebuilds (diff)
downloadhistorical-01fce1c0bd6758c80357f81aadd405871c23ebb2.tar.gz
historical-01fce1c0bd6758c80357f81aadd405871c23ebb2.tar.bz2
historical-01fce1c0bd6758c80357f81aadd405871c23ebb2.zip
Run tools/make_requests if a user patch modifies the server protocol definition (bug #432348, thanks to Oliver 'oGGy' Ney).
Package-Manager: portage-2.2.0_alpha121/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/wine/wine-1.5.10.ebuild')
-rw-r--r--app-emulation/wine/wine-1.5.10.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-emulation/wine/wine-1.5.10.ebuild b/app-emulation/wine/wine-1.5.10.ebuild
index 93567a5c5cdd..92994f6a6491 100644
--- a/app-emulation/wine/wine-1.5.10.ebuild
+++ b/app-emulation/wine/wine-1.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.3 2012/08/19 02:24:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.4 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -129,11 +129,16 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785