summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-04 02:38:46 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-04 02:38:46 +0000
commit7b5e9f6759592088484fcfe21b8dcbbf006d69d4 (patch)
treea29119438497e8ac43ae1d9835dc198a5a6ae57d /app-emulation/wine/wine-9999.ebuild
parentfix Prefix library location in configure. bug 394123 (diff)
downloadhistorical-7b5e9f6759592088484fcfe21b8dcbbf006d69d4.tar.gz
historical-7b5e9f6759592088484fcfe21b8dcbbf006d69d4.tar.bz2
historical-7b5e9f6759592088484fcfe21b8dcbbf006d69d4.zip
Use the correct system AS command as the assembler; fixes text relocation in wine binaries on systems with sys-devel/clang installed (bug #455308, thanks to Dennis Schridde and Rafał Mużyło).
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0xCF0ADD61
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 2f2e70eb2089..fd02d5b7bfcf 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.130 2013/02/03 00:52:52 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.131 2013/02/04 02:38:40 tetromino Exp $
EAPI="5"
-inherit autotools eutils flag-o-matic gnome2-utils multilib pax-utils
+inherit autotools eutils flag-o-matic gnome2-utils multilib pax-utils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
@@ -155,6 +155,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
+ epatch "${FILESDIR}"/${PN}-1.5.23-winebuild-CCAS.patch #455308
[[ ${PV} == "9999" ]] || epatch "../${PULSE_PATCHES}"/*.patch #421365
epatch_user #282735
if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
@@ -211,6 +212,7 @@ do_configure() {
$(use_with xinerama) \
$(use_with xml) \
$(use_with xml xslt) \
+ CCAS="$(tc-getAS)" \
$2
emake -j1 depend