summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-14 13:43:28 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-14 13:43:28 +0000
commit0940826e2a7b51b7f1ac74913eee158c3c2f42c0 (patch)
tree708a32b1c6467c5d10a683f939d333c0135b4498 /app-emulation/wine
parentfix bug #3728 - two lines had to be exchanged, see the bug (diff)
downloadhistorical-0940826e2a7b51b7f1ac74913eee158c3c2f42c0.tar.gz
historical-0940826e2a7b51b7f1ac74913eee158c3c2f42c0.tar.bz2
historical-0940826e2a7b51b7f1ac74913eee158c3c2f42c0.zip
Sart closing #2483: split off the wine manpages, which take a lot longer to generate than wine itself
takes to compile, into a separate package app-doc/wine-doc. winex to follow.
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/digest-wine-20020605-r11
-rw-r--r--app-emulation/wine/wine-20020605-r1.ebuild97
3 files changed, 106 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index abbe5dccab55..f0ecec5455f9 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.9 2002/06/07 10:17:49 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.10 2002/06/14 13:43:28 danarmak Exp $
+
+*wine-20020605-r1 (14 Jun 2002)
+
+ 14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Split off the documentation because manpage generation takes such a long
+ time. The docs now live in app-doc/wine-doc.
*wine-20020605 (07 Jun 2002)
diff --git a/app-emulation/wine/files/digest-wine-20020605-r1 b/app-emulation/wine/files/digest-wine-20020605-r1
new file mode 100644
index 000000000000..70e8f9b2efd3
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020605-r1
@@ -0,0 +1 @@
+MD5 416ca5a002a3286953afc77bee20a9da Wine-20020605.tar.gz 7242801
diff --git a/app-emulation/wine/wine-20020605-r1.ebuild b/app-emulation/wine/wine-20020605-r1.ebuild
new file mode 100644
index 000000000000..2cdb947d2db9
--- /dev/null
+++ b/app-emulation/wine/wine-20020605-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020605-r1.ebuild,v 1.1 2002/06/14 13:43:28 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/wine \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEMAKEOPTS="prefix=${D}/usr \
+ mandir=${D}/usr/wine/man \
+ includedir=${D}/usr/wine/include \
+ exec_prefix=${D}/usr/wine"
+
+ cd ${S}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/wine/bin
+ chmod a-x *.so
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /etc/wine
+ doins samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.wine
+ dosym /etc/wine/config /etc/skel/.wine/config
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80wine
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing wine for the first time,
+copy /etc/wine/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, wine will
+not run.
+Also, run \"regapi setValue < /etc/wine/winedefault.reg\" to setup
+per-user registry for using wine. More info in /usr/share/doc/wine-${PV}."
+
+}
+