summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-09-01 00:41:08 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-09-01 00:41:08 +0000
commit7e3e78d794052860ce35f5ae8b2adc89b39de38b (patch)
tree66f5acf1cce441a1dcbcc0a0b2f2770d76c85424 /app-emulation/xen-tools/files
parentVersion bump to Xen 3.3 (bug #201792). (diff)
downloadhistorical-7e3e78d794052860ce35f5ae8b2adc89b39de38b.tar.gz
historical-7e3e78d794052860ce35f5ae8b2adc89b39de38b.tar.bz2
historical-7e3e78d794052860ce35f5ae8b2adc89b39de38b.zip
Version bump to Xen 3.3 (bug #201792). Fixes bugs:
* Add USE flags for ACM and FLASK Xen Security Modules * Properly compile and uninstall python bytecode * RDEPEND on pyxml (bug #201255) * Remove libvncserver dependency * Shutdown xendomains in reverse start order (bug #210445) * Allow for parallel shutdown of xendomains (bug #162833) * Check that python is built with threading (bug #236092) Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc4-git1 x86_64
Diffstat (limited to 'app-emulation/xen-tools/files')
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.0--as-needed.patch30
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.0-nostrip.patch26
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch12
-rw-r--r--app-emulation/xen-tools/files/xendomains.confd4
-rwxr-xr-xapp-emulation/xen-tools/files/xendomains.initd20
5 files changed, 87 insertions, 5 deletions
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.0--as-needed.patch b/app-emulation/xen-tools/files/xen-tools-3.3.0--as-needed.patch
new file mode 100644
index 000000000000..f320bd33d7ec
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.0--as-needed.patch
@@ -0,0 +1,30 @@
+# HG changeset patch
+# User Keir Fraser <keir.fraser@citrix.com>
+# Date 1219920254 -3600
+# Node ID e92dedc72471c02c8d6b05b74afed0d32ae86171
+# Parent 18a18a7dec2b6ad8eabb3281a1535e8bec05d8d5
+tools/xenmon/Makefile: Move LDFLAGS after $<
+
+gcc expects libraries needed for object files to be specified after
+the object. Linking usually does not fail, unless it is optimized (for
+instance, using -Wl,-as-needed).
+
+The related Gentoo bug is 135145 [ https://bugs.gentoo.org/135145 ].
+
+From: Robert Buchholz <rbu@gentoo.org>
+Signed-off-by: Keir Fraser <keir.fraser@citrix.com>
+xen-unstable changeset: 18386:ab8212bd5604f58635e2b8bc6ffec6eddd211cf9
+xen-unstable date: Wed Aug 27 15:02:38 2008 +0100
+
+--- a/tools/xenmon/Makefile Thu Aug 28 11:43:40 2008 +0100
++++ b/tools/xenmon/Makefile Thu Aug 28 11:44:14 2008 +0100
+@@ -42,6 +42,6 @@ clean:
+
+
+ %: %.c Makefile
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $< $(LDFLAGS) -o $@
+ xentrace_%: %.c Makefile
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $< $(LDFLAGS) -o $@
+
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.0-nostrip.patch b/app-emulation/xen-tools/files/xen-tools-3.3.0-nostrip.patch
new file mode 100644
index 000000000000..48e7cd5778bc
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.0-nostrip.patch
@@ -0,0 +1,26 @@
+Index: xen-3.3.0/tools/ioemu-qemu-xen/Makefile
+===================================================================
+--- xen-3.3.0.orig/tools/ioemu-qemu-xen/Makefile
++++ xen-3.3.0/tools/ioemu-qemu-xen/Makefile
+@@ -205,7 +205,7 @@ endif
+ install: all $(if $(BUILD_DOCS),install-doc)
+ mkdir -p "$(DESTDIR)$(bindir)"
+ ifneq ($(TOOLS),)
+- $(INSTALL) -m 755 -s $(TOOLS) "$(DESTDIR)$(bindir)"
++ $(INSTALL) -m 755 $(TOOLS) "$(DESTDIR)$(bindir)"
+ endif
+ mkdir -p "$(DESTDIR)$(datadir)"
+ set -e; for x in bios.bin vgabios.bin vgabios-cirrus.bin ppc_rom.bin \
+Index: xen-3.3.0/tools/ioemu-qemu-xen/Makefile.target
+===================================================================
+--- xen-3.3.0.orig/tools/ioemu-qemu-xen/Makefile.target
++++ xen-3.3.0/tools/ioemu-qemu-xen/Makefile.target
+@@ -707,7 +707,7 @@ clean:
+
+ install: all install-hook
+ ifneq ($(PROGS),)
+- $(INSTALL) -m 755 -s $(PROGS) "$(DESTDIR)$(bindir)"
++ $(INSTALL) -m 755 $(PROGS) "$(DESTDIR)$(bindir)"
+ endif
+
+ # Include automatically generated dependency files
diff --git a/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch b/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch
new file mode 100644
index 000000000000..f1039d89fac5
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.3.0-xen-detect-nopie-fix.patch
@@ -0,0 +1,12 @@
+Index: xen-3.3.0/tools/misc/Makefile
+===================================================================
+--- xen-3.3.0.orig/tools/misc/Makefile
++++ xen-3.3.0/tools/misc/Makefile
+@@ -51,3 +51,7 @@ clean:
+
+ xenperf: %: %.o Makefile
+ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LDFLAGS_libxenctrl)
++
++xen-detect: %: %.c Makefile
++ $(CC) $(CFLAGS) $(LDFLAGS) $(call cc-option,$(CC),-nopie,) -o $@ $<
++
diff --git a/app-emulation/xen-tools/files/xendomains.confd b/app-emulation/xen-tools/files/xendomains.confd
index f1d810d6ce4f..90c1f5256c62 100644
--- a/app-emulation/xen-tools/files/xendomains.confd
+++ b/app-emulation/xen-tools/files/xendomains.confd
@@ -2,6 +2,8 @@
# Directory of domains to boot. AUTODIR should contain one or more symlinks
# to domain config files in /etc/xen
-
AUTODIR=/etc/xen/auto
+# Send shutdown commands to all domains in parallel instead of waiting for
+# each to shutdown individually
+PARALLEL_SHUTDOWN=yes
diff --git a/app-emulation/xen-tools/files/xendomains.initd b/app-emulation/xen-tools/files/xendomains.initd
index 59db8f62b4b5..9d8a06392485 100755
--- a/app-emulation/xen-tools/files/xendomains.initd
+++ b/app-emulation/xen-tools/files/xendomains.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/files/xendomains.initd,v 1.2 2007/05/02 04:10:04 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/files/xendomains.initd,v 1.3 2008/09/01 00:41:08 rbu Exp $
opts="start stop status restart"
@@ -53,7 +53,7 @@ start() {
fi
fi
# Create all domains with config files in AUTODIR.
- for dom in $(ls "${AUTODIR}/"* 2>/dev/null); do
+ for dom in $(ls "${AUTODIR:=/etc/xen/auto}/"* 2>/dev/null | sort); do
name=$(get_domname ${dom})
if ! is_running ${name} ; then
ebegin " Starting domain ${name}"
@@ -74,10 +74,22 @@ stop() {
einfo "Shutting down Xen domains from ${AUTODIR:=/etc/xen/auto}"
# Stop all domains with config files in AUTODIR.
- for dom in $(ls "${AUTODIR}/"* 2>/dev/null); do
+ DOMAINS="$(ls "${AUTODIR:=/etc/xen/auto}/"* 2>/dev/null | sort -r)"
+
+ if [[ "$PARALLEL_SHUTDOWN" = "yes" ]] ; then
+ for dom in $DOMAINS ; do
+ name=$(get_domname ${dom})
+ if is_running ${name} ; then
+ ebegin " Asking domain ${name} to shutdown..."
+ xm shutdown ${name} >/dev/null
+ eend $?
+ fi
+ done
+ fi
+ for dom in $DOMAINS ; do
name=$(get_domname ${dom})
if is_running ${name} ; then
- ebegin " Stopping domain ${name}"
+ ebegin " Waiting for domain ${name} to shutdown"
xm shutdown --wait ${name} >/dev/null
eend $?
else