summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-24 03:10:38 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-24 03:10:38 +0000
commitf1da4abf3615ac5f132fc78b0c0ef53848a52a2e (patch)
tree892cf1d37b56f12d44af90e906425fdec3647cc6 /app-emulation/xmame
parentFixed bogus dates. (diff)
downloadhistorical-f1da4abf3615ac5f132fc78b0c0ef53848a52a2e.tar.gz
historical-f1da4abf3615ac5f132fc78b0c0ef53848a52a2e.tar.bz2
historical-f1da4abf3615ac5f132fc78b0c0ef53848a52a2e.zip
Fixes a compile error with -O3 optimizations; reverts to -O2. Fixes #5258.
Diffstat (limited to 'app-emulation/xmame')
-rw-r--r--app-emulation/xmame/ChangeLog7
-rw-r--r--app-emulation/xmame/xmame-0.60.1-r2.ebuild8
2 files changed, 13 insertions, 2 deletions
diff --git a/app-emulation/xmame/ChangeLog b/app-emulation/xmame/ChangeLog
index 843ad5630248..4e99e5f5427c 100644
--- a/app-emulation/xmame/ChangeLog
+++ b/app-emulation/xmame/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-games/xmame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.6 2002/07/16 02:56:20 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.7 2002/07/24 03:10:38 rphillips Exp $
*xmame-0.60.1-r2 (13 June 2002)
+ 23 Jul 2002; Ryan Phillips <rphillips@gentoo.org> :
+
+ on x86 platforms -O3 doesn't compile. I included a sed statement
+ to replace -O3 with -O2.
+
15 Jul 2002; Owen Stampflee <owen@gentoo.org> :
Added KEYWORDS.
diff --git a/app-emulation/xmame/xmame-0.60.1-r2.ebuild b/app-emulation/xmame/xmame-0.60.1-r2.ebuild
index fc954699489e..93526c2de3f7 100644
--- a/app-emulation/xmame/xmame-0.60.1-r2.ebuild
+++ b/app-emulation/xmame/xmame-0.60.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Based on the 0.59.1 ebuild by Ben Lutgens <blutgens@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.60.1-r2.ebuild,v 1.3 2002/07/16 02:56:20 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.60.1-r2.ebuild,v 1.4 2002/07/24 03:10:38 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Multiple Arcade Machine Emulator for X11"
@@ -65,6 +65,8 @@ src_unpack() {
}
src_compile() {
+ local MYFLAGS
+ MYFLAGS=""
if [ ${ARCH} = "ppc" ] ; then
# add Makefile suggested flags for ppc
@@ -72,6 +74,10 @@ src_compile() {
-fstrength-reduce -fomit-frame-pointer -ffast-math -fsigned-char"
else
MYFLAGS="${CFLAGS}"
+
+ # rphillips 23 Jul 2002
+ # compile doesn't work on x86 platforms with -O3 optimizations
+ MYFLAGS=`echo $MYFLAGS | sed 's/-O3/-O2/'`
fi
emake CFLAGS="${MYFLAGS}" || die
}