summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-10-15 14:55:37 +0000
committerTilman Klar <phoenix@gentoo.org>2002-10-15 14:55:37 +0000
commit4ae3829a394b7cd3c80b1404ffbad3ee57250877 (patch)
tree3c7f6cf07217581bb6f2f25709ce3f160d1f9b74 /app-emulation
parentgive credit properly (diff)
downloadhistorical-4ae3829a394b7cd3c80b1404ffbad3ee57250877.tar.gz
historical-4ae3829a394b7cd3c80b1404ffbad3ee57250877.tar.bz2
historical-4ae3829a394b7cd3c80b1404ffbad3ee57250877.zip
Major rewrite of wine-20021007.ebuild - check the ChangeLog.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog20
-rw-r--r--app-emulation/wine/files/wine-20021007-config299
-rw-r--r--app-emulation/wine/files/wine-20021007-fake_windows.tar.bz2bin0 -> 500 bytes
-rw-r--r--app-emulation/wine/files/wine-20021007-misc.tar.bz2bin0 -> 4544 bytes
-rw-r--r--app-emulation/wine/files/wine-20021007-regedit20
-rw-r--r--app-emulation/wine/files/wine-20021007-wine48
-rw-r--r--app-emulation/wine/wine-20021007.ebuild57
7 files changed, 50 insertions, 394 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index aa0429af68bf..00fe9dc5449e 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,10 +1,24 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.20 2002/10/12 13:12:23 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.21 2002/10/15 14:55:37 phoenix Exp $
-*wine-20020904-r1 (12 Oct 2002)
+*wine-20021007 (12 Oct 2002)
- 12 Oct 2002; phoen][x <phoenix@gentoo.org> wine-20020 .ebuild, ChangeLog :
+ 15 Oct 2002; phoen][x <phoenix@gentoo.org> wine-20021007.ebuild, ChangeLog,
+ files/wine-20021007-fake_windows.tar.bz2, files/wine-20021007-misc.tar.bz2 :
+
+ Major rewrite:
+ - config, regedit-wine and wine are now in a tarball called ${P}-misc.tar.bz2
+ - the fake_windows tarball ( ${P}-fake_windows.tar.bz2 ) goes to ${FILESDIR} now
+ - regedit-wine uses the new bin/regedit instead of bin/regapi ( see bug #9001 )
+ - the default config is useful now ( running stuff outta the box should work )
+ - the wine wrapper ( /usr/bin/wine ) uses /usr/bin/regedit for the initial
+ import of winedefault.reg
+ - using do{ins,bin} over mv/cp
+ - fixed permissions in /usr/lib/wine/.data
+ - added lots of comments
+
+ 12 Oct 2002; phoen][x <phoenix@gentoo.org> wine-20021007.ebuild, ChangeLog :
Bumped to new version.
diff --git a/app-emulation/wine/files/wine-20021007-config b/app-emulation/wine/files/wine-20021007-config
deleted file mode 100644
index 05616fe8d54f..000000000000
--- a/app-emulation/wine/files/wine-20021007-config
+++ /dev/null
@@ -1,299 +0,0 @@
-WINE REGISTRY Version 2
-;; All keys relative to \\Machine\\Software\\Wine\\Wine\\Config
-
-;; If you think it is necessary to show others your complete config for a
-;; bug report, filter out empty lines and comments with
-;; grep -v "^;" ~/.wine/config | grep '.'
-;;
-;; MS-DOS drives configuration
-;;
-;; Each section has the following format:
-;; [Drive X]
-;; "Path"="xxx" (Unix path for drive root)
-;; "Type"="xxx" (supported types are 'floppy', 'hd', 'cdrom' and 'network')
-;; "Label"="xxx" (drive label, at most 11 characters)
-;; "Serial"="xxx" (serial number, 8 characters hexadecimal number)
-;; "Filesystem"="xxx" (supported types are 'msdos'/'dos'/'fat', 'win95'/'vfat', 'unix')
-;; This is the FS Wine is supposed to emulate on a certain
-;; directory structure.
-;; Recommended:
-;; - "win95" for ext2fs, VFAT and FAT32
-;; - "msdos" for FAT16 (ugly, upgrading to VFAT driver strongly recommended)
-;; DON'T use "unix" unless you intend to port programs using Winelib !
-;; "Device"="/dev/xx" (only if you want to allow raw device access)
-;;
-[Drive A]
-"Path" = "/mnt/fd0"
-"Type" = "floppy"
-"Label" = "Floppy"
-"Filesystem" = "win95"
-"Serial" = "87654321"
-"Device" = "/dev/fd0"
-
-[Drive C]
-"Path" = "/c"
-"Type" = "hd"
-"Label" = "MS-DOS"
-"Filesystem" = "win95"
-
-[Drive D]
-"Path" = "/cdrom"
-"Type" = "cdrom"
-"Label" = "CD-Rom"
-"Filesystem" = "win95"
-; make sure that device is correct and has proper permissions !
-"Device" = "/dev/cdrom"
-
-[Drive E]
-"Path" = "/tmp"
-"Type" = "hd"
-"Label" = "Tmp Drive"
-"Filesystem" = "win95"
-
-[Drive F]
-"Path" = "${HOME}"
-"Type" = "network"
-"Label" = "Home"
-"Filesystem" = "win95"
-
-[wine]
-"Windows" = "c:\\windows"
-"System" = "c:\\windows\\system"
-"Temp" = "e:\\"
-"Path" = "c:\\windows;c:\\windows\\system;e:\\;e:\\test;f:\\"
-"Profile" = "c:\\windows\\Profiles\\Administrator"
-"GraphicsDriver" = "x11drv"
-; Wine doesn't pass directory symlinks to Windows programs by default.
-; Enabling this may crash some programs that do recursive lookups of a whole
-; subdir tree in case of a symlink pointing back to itself.
-;"ShowDirSymlinks" = "1"
-"ShellLinker" = "wineshelllink"
-
-# <wineconf>
-
-[Version]
-; Windows version to imitate (win95,win98,winme,nt351,nt40,win2k,winxp,win20,win30,win31)" },
-;"Windows" = "win98"
-; DOS version to imitate
-;"DOS" = "6.22"
-
-; Be careful here, wrong DllOverrides settings have the potential
-; to pretty much kill your setup.
-[DllOverrides]
-"rpcrt4" = "builtin, native"
-"oleaut32" = "builtin, native"
-"ole32" = "builtin, native"
-"commdlg" = "builtin, native"
-"comdlg32" = "builtin, native"
-"ver" = "builtin, native"
-"version" = "builtin, native"
-"shell" = "builtin, native"
-"shell32" = "builtin, native"
-"shfolder" = "builtin, native"
-"shlwapi" = "builtin, native"
-"shdocvw" = "builtin, native"
-"lzexpand" = "builtin, native"
-"lz32" = "builtin, native"
-"comctl32" = "builtin, native"
-"commctrl" = "builtin, native"
-"advapi32" = "builtin, native"
-"crtdll" = "builtin, native"
-"mpr" = "builtin, native"
-"winspool.drv" = "builtin, native"
-"ddraw" = "builtin, native"
-"dinput" = "builtin, native"
-"dsound" = "builtin, native"
-"opengl32" = "builtin, native"
-"msvcrt" = "native, builtin"
-"msvideo" = "builtin, native"
-"msvfw32" = "builtin, native"
-"mcicda.drv" = "builtin, native"
-"mciseq.drv" = "builtin, native"
-"mciwave.drv" = "builtin, native"
-"mciavi.drv" = "native, builtin"
-"mcianim.drv" = "native, builtin"
-"msacm.drv" = "builtin, native"
-"msacm" = "builtin, native"
-"msacm32" = "builtin, native"
-"midimap.drv" = "builtin, native"
-; you can specify applications too
-"notepad.exe" = "native, builtin"
-; default for all other dlls
-"*" = "native, builtin"
-
-[x11drv]
-; Number of colors to allocate from the system palette
-"AllocSystemColors" = "100"
-; Use a private color map
-"PrivateColorMap" = "N"
-; Favor correctness over speed in some graphics operations
-"PerfectGraphics" = "N"
-; Color depth to use on multi-depth screens
-;;"ScreenDepth" = "16"
-; Name of X11 display to use
-;;"Display" = ":0.0"
-; Allow the window manager to manage created windows
-"Managed" = "Y"
-; Use a desktop window of 640x480 for Wine
-;"Desktop" = "640x480"
-; Use XFree86 DGA extension if present
-; (make sure /dev/mem is accessible by you !)
-"UseDGA" = "Y"
-; Use XShm extension if present
-"UseXShm" = "Y"
-; Use XVidMode extension if present
-"UseXVidMode" = "Y"
-; Enable DirectX mouse grab
-"DXGrab" = "N"
-; Create the desktop window with a double-buffered visual
-; (useful to play OpenGL games)
-"DesktopDoubleBuffered" = "N"
-; Code page used for captions in managed mode
-; 0 means default ANSI code page (CP_ACP == 0)
-"TextCP" = "0"
-; Use this if you have more than one port for video on your setup
-; (Wine uses for now the first 'input image' it finds).
-;; "XVideoPort" = "43"
-; Run in synchronous mode (useful for debugging X11 problems)
-;;"Synchronous" = "Y"
-
-[fonts]
-;Read the Fonts topic in the Wine User Guide before adding aliases
-;See a couple of examples for russian users below
-"Resolution" = "96"
-"Default" = "-adobe-helvetica-"
-"DefaultFixed" = "fixed"
-"DefaultSerif" = "-adobe-times-"
-"DefaultSansSerif" = "-adobe-helvetica-"
-
-;; default TrueType fonts with russian koi8-r encoding
-;"Default" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
-;"DefaultFixed" = "-monotype-courier new-*-*-*--*-*-*-*-*-*-koi8-r"
-;"DefaultSerif" = "-monotype-times new roman-*-*-*--*-*-*-*-*-*-koi8-r"
-;"DefaultSansSerif" = "-monotype-arial-*-*-*--*-*-*-*-*-*-koi8-r"
-;; default cyrillic bitmap X fonts
-;"Default" = "-cronyx-helvetica-"
-;"DefaultFixed" = "fixed"
-;"DefaultSerif" = "-cronyx-times-"
-;"DefaultSansSerif" = "-cronyx-helvetica-"
-
-; the TrueType font dirs you want to make accessible to wine
-[FontDirs]
-;"dir1" = "/usr/X11R6/lib/X11/fonts/TrueType"
-;"dir2" = "/usr/share/fonts/truetype"
-;"dir3" = "/usr/X11R6/lib/X11/fonts/TT"
-;"dir4" = "/usr/share/fonts/TT"
-
-[serialports]
-"Com1" = "/dev/ttyS0"
-"Com2" = "/dev/ttyS1"
-"Com3" = "/dev/ttyS2"
-"Com4" = "/dev/modem"
-
-[parallelports]
-"Lpt1" = "/dev/lp0"
-
-[ppdev]
-;; key: io-base of the emulated port
-;; value : parport-device{,timeout}
-;; timeout for auto closing an open device ( not yet implemented)
-;"378" = "/dev/parport0"
-;"278" = "/dev/parport1"
-;"3bc" = "/dev/parport2"
-
-[spooler]
-"FILE:" = "tmp.ps"
-"LPT1:" = "|lpr"
-"LPT2:" = "|gs -sDEVICE=bj200 -sOutputFile=/tmp/fred -q -"
-"LPT3:" = "/dev/lp3"
-
-[ports]
-;"read" = "0x779,0x379,0x280-0x2a0"
-;"write" = "0x779,0x379,0x280-0x2a0"
-
-[Debug]
-;"RelayExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
-;"RelayInclude" = "user32.CreateWindowA"
-;"SnoopExclude" = "RtlEnterCriticalSection;RtlLeaveCriticalSection"
-;"SpyExclude" = "WM_SIZE;WM_TIMER;"
-
-[registry]
-;These are all booleans. Y/y/T/t/1 are true, N/n/F/f/0 are false.
-;Defaults are read all, write to Home
-; Global registries (stored in /etc)
-"LoadGlobalRegistryFiles" = "Y"
-; Home registries (stored in ~user/.wine/)
-"LoadHomeRegistryFiles" = "Y"
-; Load Windows registries from the Windows directory
-"LoadWindowsRegistryFiles" = "Y"
-; TRY to write all changes to home registries
-"WritetoHomeRegistryFiles" = "Y"
-; Registry periodic save timeout in seconds
-; "PeriodicSave" = "600"
-; Save only modified keys
-"SaveOnlyUpdatedKeys" = "Y"
-
-[Tweak.Layout]
-;; supported styles are 'Win31'(default), 'Win95', 'Win98'
-;; this has *nothing* to do with the windows version Wine returns:
-;; set the "Windows" value in the [Version] section if you want that.
-"WineLook" = "Win95"
-
-[Console]
-;"Drivers" = "tty"
-;"XtermProg" = "nxterm"
-;"InitialRows" = "25"
-;"InitialColumns" = "80"
-;"TerminalType" = "nxterm"
-
-[Clipboard]
-"ClearAllSelections" = "0"
-"PersistentSelection" = "1"
-
-; List of all directories directly contain .AFM files
-[afmdirs]
-"1" = "/usr/share/ghostscript/fonts"
-"2" = "/usr/share/a2ps/afm"
-"3" = "/usr/share/enscript"
-"4" = "/usr/X11R6/lib/X11/fonts/Type1"
-
-[WinMM]
-"Drivers" = "wineoss.drv"
-#"Drivers" = "winearts.drv"
-"WaveMapper" = "msacm.drv"
-"MidiMapper" = "midimap.drv"
-
-[dsound]
-;; HEL only: Number of waveOut fragments ahead to mix in new buffers.
-;"HELmargin" = "5"
-;; HEL only: Number of waveOut fragments ahead to queue to driver.
-;"HELqueue" = "5"
-;; Max number of fragments to prebuffer
-;"SndQueueMax" = "28"
-;; Min number of fragments to prebuffer
-;"SndQueueMin" = "12"
-
-;; sample AppDefaults entries
-;[AppDefaults\\iexplore.exe\\DllOverrides]
-;"shlwapi" = "native"
-;"rpcrt4" = "native"
-;"ole32" = "native"
-;"shdocvw" = "native"
-;"wininet" = "native"
-;"shfolder" = "native"
-;"shell32" = "native"
-;"shell" = "native"
-;"comctl32" = "native"
-;
-;[AppDefaults\\setup.exe\\x11drv]
-;"Desktop" = "800x600"
-;
-;[AppDefaults\\sol.exe\\Version]
-;"Windows" = "nt40"
-;
-;; Some games (Quake 2, UT) refuse to accept emulated dsound devices.
-;; You can add an AppDefault entry like this for such cases.
-;[AppDefaults\\pickygame.exe\\dsound]
-;"EmulDriver" = "N"
-
-# </wineconf>
diff --git a/app-emulation/wine/files/wine-20021007-fake_windows.tar.bz2 b/app-emulation/wine/files/wine-20021007-fake_windows.tar.bz2
new file mode 100644
index 000000000000..d60f11e08ee3
--- /dev/null
+++ b/app-emulation/wine/files/wine-20021007-fake_windows.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20021007-misc.tar.bz2 b/app-emulation/wine/files/wine-20021007-misc.tar.bz2
new file mode 100644
index 000000000000..09c2b719ffa3
--- /dev/null
+++ b/app-emulation/wine/files/wine-20021007-misc.tar.bz2
Binary files differ
diff --git a/app-emulation/wine/files/wine-20021007-regedit b/app-emulation/wine/files/wine-20021007-regedit
deleted file mode 100644
index 129bba0ab047..000000000000
--- a/app-emulation/wine/files/wine-20021007-regedit
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/bash
-# The wine regapi wrapper
-
-export INSTALLDIR="/usr/lib/wine"
-
-export WINEPREFIX="$HOME/.wine"
-
-export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
-export WINEDLLPATH="$LD_LIBRARY_PATH"
-
-export WINE_LOADER=wine
-
-export RUNWINE="$INSTALLDIR/bin/wine"
-export REGAPI="$INSTALLDIR/bin/regapi"
-
-if([ -z ${1} ]) then
- echo "Usage: regedit foo.reg"
-else
- "$REGAPI" setValue < ${1} &> /dev/null
-fi
diff --git a/app-emulation/wine/files/wine-20021007-wine b/app-emulation/wine/files/wine-20021007-wine
deleted file mode 100644
index 19b32fac8c21..000000000000
--- a/app-emulation/wine/files/wine-20021007-wine
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/bash
-# The wine wrapper
-
-# Kindly distributed by Martin Schlemmer
-# Modified by phoen][x
-
-export INSTALLDIR="/usr/lib/wine"
-
-export WINEPREFIX="$HOME/.wine"
-
-export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
-export WINEDLLPATH="$LD_LIBRARY_PATH"
-
-export WINE_LOADER=wine
-
-export RUNWINE="$INSTALLDIR/bin/wine"
-export REGAPI="$INSTALLDIR/bin/regapi"
-
-if [ ! -f $WINEPREFIX/config ]
-then
- echo "!! ~/.wine/config misses"
- echo "!! Setting up a config file"
-
- mkdir -p $WINEPREFIX/fake_windows
-
- # First copy in the new config file.
- cp "$INSTALLDIR/.data/config" "$WINEPREFIX/config"
-
- echo "!! Setting up ~/.wine/fake_windows/"
- cp -R $INSTALLDIR/.data/fake_windows/* $WINEPREFIX/fake_windows
-
- echo "!! Setting up default registry."
- "$REGAPI" setValue < "$INSTALLDIR/.data/winedefault.reg" &> /dev/null
-
- echo "!! Installation complete."
- echo "!! Set the correct path for drive D and E in ~/.wine/config and uncomment the sections, please"
- exit
-fi
-
-# Force the use of the more memory-efficient MSVC 5 allocator with
-# any programs that use MSVCRT. This reduces memory consumption
-# significantly.
-export __MSVCRT_HEAP_SELECT=__GLOBAL_HEAP_SELECTED,2
-
-
-PATH="$INSTALLDIR/bin:$PATH"
-
-"$RUNWINE" --debugmsg -all "$@"
diff --git a/app-emulation/wine/wine-20021007.ebuild b/app-emulation/wine/wine-20021007.ebuild
index 57f81eb9c3f7..043b810a9d93 100644
--- a/app-emulation/wine/wine-20021007.ebuild
+++ b/app-emulation/wine/wine-20021007.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20021007.ebuild,v 1.1 2002/10/12 13:12:23 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20021007.ebuild,v 1.2 2002/10/15 14:55:37 phoenix Exp $
IUSE="nas arts cups opengl alsa"
-DESCRIPTION="Wine is a free implementation of Windows on Unix."
+DESCRIPTION="Wine is a free implementation of Windows(tm) on Unix."
SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
HOMEPAGE="http://www.winehq.com/"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 -ppc -sparc -sparc64"
-
DEPEND="virtual/x11
sys-devel/gcc
sys-devel/flex
@@ -47,41 +45,56 @@ src_compile() {
cp Makefile 1
sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+ # No parallel make
cd ${S}
make depend all || die
cd programs && emake || die
-
}
src_install () {
-
local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+ ### Install wine to ${D}
cd ${S}
make ${WINEMAKEOPTS} install || die
cd ${S}/programs
make ${WINEMAKEOPTS} install || die
- # Creates /usr/lib/wine/.data with fake_windows in it
- # This is needed for our wine wrapper script
+ # Needed for later installation
+ mkdir -p ${D}/usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
mkdir ${D}/usr/lib/wine/.data
- cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/wine/.data
- cp ${FILESDIR}/${P}-config ${D}/usr/lib/wine/.data/config
- cp ${WORKDIR}/${P}/winedefault.reg ${D}/usr/lib/wine/.data/winedefault.reg
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
- # Install the wrapper script
- mkdir ${D}/usr/bin
- cp ${FILESDIR}/${P}-wine ${D}/usr/bin/wine
- cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-wine
+ # Unpacking the miscellaneous files
+ tar jxvf ${FILESDIR}/${P}-misc.tar.bz2
+ chown root:root config
- # Take care of the documentation
- cd ${S}
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine
+ rm regedit-wine wine
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
insinto /usr/lib/wine/.data/fake_windows/Windows
doins documentation/samples/system.ini
doins documentation/samples/generic.ppd
-
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
# Manpage setup
cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
@@ -100,9 +113,5 @@ pkg_postinst() {
einfo "* wine registry. *"
einfo "* If you have further questions, enhancements or patches *"
einfo "* send an email to phoenix@gentoo.org *"
- einfo "* *"
- einfo "* Manpage has been installed to the system. *"
- einfo "* \"man wine\" should show it. *"
einfo "**********************************************************************"
-}
-
+} \ No newline at end of file