summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBartosch Pixa <darkspecter@gentoo.org>2003-02-20 21:58:26 +0000
committerBartosch Pixa <darkspecter@gentoo.org>2003-02-20 21:58:26 +0000
commita1bdb7f627ce9832f473291b72e13d323456040a (patch)
treece88be4e38a53d1099d757a1c47580c7d17718bb /app-emulation
parentrevamp, cleanout, gnome2.eclass (diff)
downloadhistorical-a1bdb7f627ce9832f473291b72e13d323456040a.tar.gz
historical-a1bdb7f627ce9832f473291b72e13d323456040a.tar.bz2
historical-a1bdb7f627ce9832f473291b72e13d323456040a.zip
added RDEPEND and a minor Makefile patch neede for ppc, set ~ppc
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/snes9x/ChangeLog7
-rw-r--r--app-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff37
-rw-r--r--app-emulation/snes9x/snes9x-139-r1.ebuild13
3 files changed, 53 insertions, 4 deletions
diff --git a/app-emulation/snes9x/ChangeLog b/app-emulation/snes9x/ChangeLog
index 67b5e0d5e928..82c89a7f7f04 100644
--- a/app-emulation/snes9x/ChangeLog
+++ b/app-emulation/snes9x/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/snes9x
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.9 2003/02/12 04:03:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/ChangeLog,v 1.10 2003/02/20 21:58:26 darkspecter Exp $
+
+*snes9x-139-r1 (20 Feb 2003)
+
+ 20 Feb 2003; Bartosch Pixa <darkspecter@gentoo.org> snes9x-139-r1.ebuild :
+ added a patch to enable fallback to c routines, RDEPEND and set ~ppc in keywords
*snes-139-r1 (27 Jul 2002)
diff --git a/app-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff b/app-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff
new file mode 100644
index 000000000000..09fee05cb903
--- /dev/null
+++ b/app-emulation/snes9x/files/snes9x-139-r1-Makefile-ppc.diff
@@ -0,0 +1,37 @@
+--- release.orig/Makefile.linux 2003-02-11 05:27:20.000000000 +0000
++++ release/Makefile.linux 2003-02-11 05:28:24.000000000 +0000
+@@ -1,13 +1,13 @@
+-ZSNESFX=1
+-ZSNESC4=1
+-ASMCPU=1
++#ZSNESFX=1
++#ZSNESC4=1
++#ASMCPU=1
+ #SPC700ASM=1
+ NETPLAY=1
+ UNZIP=1
+ #GLIDE=1
+ #OPENGL=1
+ THREAD_SOUND=1
+-ASMKREED=1
++#ASMKREED=1
+
+ ifdef ZSNESFX
+ FXOBJ=i386/fxemu2b.o i386/fxemu2.o i386/fxemu2c.o i386/fxtable.o i386/sfxproc.o i386/zsnes.o
+@@ -39,7 +39,7 @@
+ SOUNDOBJ=spctool/spc700.o spctool/dsp.o spctool.o spctool/soundmod.o spc.o
+ SOUNDDEFINES=-DSPCTOOL
+ else
+-SOUNDOBJ=spc700.o soundux.o apu.o i386/spc.o
++SOUNDOBJ=spc700.o soundux.o apu.o
+ SOUNDDEFINES=-DSPC700_C
+ endif
+
+@@ -111,7 +111,6 @@
+ OPTIMISE=
+
+ CCFLAGS = $(OPTIMISE) -DMITSHM \
+--Ii386 \
+ -I. \
+ -Iunzip \
+ -DJOYSTICK_SUPPORT \
diff --git a/app-emulation/snes9x/snes9x-139-r1.ebuild b/app-emulation/snes9x/snes9x-139-r1.ebuild
index 6bd0dae8b056..a3b58036119e 100644
--- a/app-emulation/snes9x/snes9x-139-r1.ebuild
+++ b/app-emulation/snes9x/snes9x-139-r1.ebuild
@@ -1,20 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.11 2003/02/13 07:16:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/snes9x/snes9x-139-r1.ebuild,v 1.12 2003/02/20 21:58:26 darkspecter Exp $
IUSE="X svga 3dfx opengl"
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="http://www.snes9x.com/"
LICENSE="as-is"
-KEYWORDS="x86 -ppc"
+KEYWORDS="x86 ~ppc"
SLOT="0"
SRC_URI="http://www.snes9x.com/zips/s9xs${PV}.zip"
-DEPEND="dev-lang/nasm
+DEPEND="x86? (dev-lang/nasm)
X? ( virtual/x11 )
svga? ( media-libs/svgalib )
opengl? ( virtual/opengl )
3dfx? ( media-libs/glide-v3 )"
+RDEPEND= X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ opengl? ( virtual/opengl )
+ 3dfx? ( media-libs/glide-v3 )"
S="${WORKDIR}/release"
pkg_setup() {
@@ -32,6 +36,9 @@ pkg_setup() {
src_compile() {
patch -p1 < ${FILESDIR}/snes9x-gcc3.diff
+ if [ `use ppc` ]; then
+ patch -p1 < ${FILESDIR}/snes9x-139-r1-Makefile-ppc.diff
+ fi
#install our custom CXXFLAGS
mv Makefile.linux Makefile