summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2011-07-16 12:57:42 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2011-07-16 12:57:42 +0000
commitc40d7616bbe863c266a1ca8e50f01158b2780efe (patch)
tree654b0883c4360168692f8e57afb035a067496235 /app-emulation
parentRaise dependencies to net-print/cups-1.4 (we won't test scp integration with ... (diff)
downloadhistorical-c40d7616bbe863c266a1ca8e50f01158b2780efe.tar.gz
historical-c40d7616bbe863c266a1ca8e50f01158b2780efe.tar.bz2
historical-c40d7616bbe863c266a1ca8e50f01158b2780efe.zip
version bump
Package-Manager: portage-2.1.10.6/cvs/Linux x86_64
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools-kmod/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-0.0.20110627.437995.ebuild78
-rw-r--r--app-emulation/open-vm-tools/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20110627.437995.ebuild123
4 files changed, 215 insertions, 2 deletions
diff --git a/app-emulation/open-vm-tools-kmod/ChangeLog b/app-emulation/open-vm-tools-kmod/ChangeLog
index 8b6d19d45f6b..2feb59840d3a 100644
--- a/app-emulation/open-vm-tools-kmod/ChangeLog
+++ b/app-emulation/open-vm-tools-kmod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools-kmod
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.15 2011/04/19 15:28:32 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.16 2011/07/16 12:56:56 vadimk Exp $
+
+*open-vm-tools-kmod-0.0.20110627.437995 (16 Jul 2011)
+
+ 16 Jul 2011; Vadim Kuznetsov <vadimk@gentoo.org>
+ +open-vm-tools-kmod-0.0.20110627.437995.ebuild:
+ version bump
*open-vm-tools-kmod-0.0.20110328.387002 (19 Apr 2011)
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-0.0.20110627.437995.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-0.0.20110627.437995.ebuild
new file mode 100644
index 000000000000..d6f4d497f7ee
--- /dev/null
+++ b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-0.0.20110627.437995.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-0.0.20110627.437995.ebuild,v 1.1 2011/07/16 12:56:56 vadimk Exp $
+
+EAPI="2"
+
+inherit linux-mod versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PN="${PN/-kmod}"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ VMWARE_MOD_DIR="modules/linux"
+ VMWARE_MODULE_LIST="vmblock vmci vmhgfs vmsync vmxnet vsock"
+
+ MODULE_NAMES=""
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
+
+ for mod in ${VMWARE_MODULE_LIST};
+ do
+ if [ "${mod}" == "vmxnet" ];
+ then
+ MODTARGET="net"
+ else
+ MODTARGET="openvmtools"
+ fi
+ MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
+ done
+}
+
+src_prepare() {
+ sed -i.bak -e '/\smake\s/s/make/$(MAKE)/g' modules/linux/{vmblock,vmci,vmhgfs,vmsync,vmxnet,vsock}/Makefile\
+ || die "Sed failed."
+}
+
+src_configure() {
+ : # do nothing at all
+}
+
+src_install() {
+ linux-mod_src_install
+
+ local udevrules="${T}/60-vmware.rules"
+ cat > "${udevrules}" <<-EOF
+ KERNEL=="vsock", GROUP="vmware", MODE=660
+ EOF
+ insinto /etc/udev/rules.d/
+ doins "${udevrules}"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog "vmxnet3 for Linux is now upstream (as of Linux 2.6.32)"
+ elog "pvscsi for Linux is now upstream (vmw_pvscsi) (as of Linux 2.6.33)"
+ elog "vmmemctl for Linux is now upstream (vmw_balloon) (as of Linux 2.6.34)"
+}
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 0356313d5a11..3311b1319a70 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.50 2011/05/02 11:15:33 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.51 2011/07/16 12:57:42 vadimk Exp $
+
+*open-vm-tools-0.0.20110627.437995 (16 Jul 2011)
+
+ 16 Jul 2011; Vadim Kuznetsov <vadimk@gentoo.org>
+ +open-vm-tools-0.0.20110627.437995.ebuild:
+ version bump
02 May 2011; Christoph Mende <angelos@gentoo.org>
open-vm-tools-0.0.20110328.387002-r2.ebuild:
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20110627.437995.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20110627.437995.ebuild
new file mode 100644
index 000000000000..8c3d25d1db2c
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20110627.437995.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20110627.437995.ebuild,v 1.1 2011/07/16 12:57:42 vadimk Exp $
+
+EAPI="2"
+
+inherit eutils pam versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu +pic unity xinerama"
+
+RDEPEND="app-emulation/open-vm-tools-kmod
+ dev-libs/glib:2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ virtual/pam
+ X? (
+ dev-cpp/gtkmm:2.4
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu )
+ unity? (
+ dev-libs/uriparser
+ media-libs/libpng
+ x11-libs/libXScrnSaver
+ )
+ xinerama? ( x11-libs/libXinerama )
+ "
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig
+ virtual/linux-sources
+ sys-apps/findutils
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use unity && ! use X && die 'The Unity USE flag requires "X" USE flag as well'
+ use unity && ! use xinerama && die 'The Unity USE flag requires xinerame USE="xinerama" as well'
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/default-scripts.patch"
+ #epatch "${FILESDIR}/checkvm-pie-safety.patch"
+ #sed -i -e 's/proc-3.2.7/proc/g' configure || die "sed configure failed"
+ # Do not filter out Werror
+ # Upstream Bug http://sourceforge.net/tracker/?func=detail&aid=2959749&group_id=204462&atid=989708
+ # sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+ sed -i -e 's:\(TEST_PLUGIN_INSTALLDIR=\).*:\1\$libdir/open-vm-tools/plugins/tests:g' configure || die "sed test_plugin_installdir failed"
+}
+
+src_configure() {
+ econf \
+ --with-procps \
+ --with-dnet \
+ --without-kernel-modules \
+ $(use_enable doc docs) \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use_with X gtk2) \
+ $(use_with X gtkmm) \
+ $(use_with icu) \
+ $(use_with pic) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon)
+
+ # Bugs 260878, 326761
+ find ./ -name Makefile | xargs sed -i -e 's/-Werror//g' || die "sed out Werror failed"
+}
+
+src_compile() {
+ emake || die "failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ rm "${D}"/usr/$(get_libdir)/*.la
+ rm "${D}"/usr/$(get_libdir)/open-vm-tools/plugins/common/*.la
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools || die "failed to newinitd"
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools || die "failed to newconfd"
+
+ if use X;
+ then
+ fperms 4755 "/usr/bin/vmware-user-suid-wrapper" || die
+
+ dobin "${S}"/scripts/common/vmware-xdg-detect-de
+
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop" || die "failed to install .desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, please add the users to the 'vmware' group."
+ fi
+ elog "Add 'vmware-tools' service to the default runlevel."
+}