summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-12 19:51:51 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-12 19:51:51 +0000
commitfd7674688f010b29473a82d01e6a9c59acc4f220 (patch)
tree9035f405060913c820fa7a639826402b421950d7 /app-emulation
parentfixed 2nd part of bug #636 (diff)
downloadhistorical-fd7674688f010b29473a82d01e6a9c59acc4f220.tar.gz
historical-fd7674688f010b29473a82d01e6a9c59acc4f220.tar.bz2
historical-fd7674688f010b29473a82d01e6a9c59acc4f220.zip
closed bug #422
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/freesci/files/digest-freesci-0.3.31
-rw-r--r--app-emulation/freesci/freesci-0.3.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/freesci/files/digest-freesci-0.3.3 b/app-emulation/freesci/files/digest-freesci-0.3.3
new file mode 100644
index 000000000000..67bffd9eb68a
--- /dev/null
+++ b/app-emulation/freesci/files/digest-freesci-0.3.3
@@ -0,0 +1 @@
+MD5 2dc962425db6b68e6b1ecc2771df8ea6 freesci-0.3.3.tar.bz2 753957
diff --git a/app-emulation/freesci/freesci-0.3.3.ebuild b/app-emulation/freesci/freesci-0.3.3.ebuild
new file mode 100644
index 000000000000..fb128bcd1895
--- /dev/null
+++ b/app-emulation/freesci/freesci-0.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: foser <foser@sesmar.eu.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/freesci/freesci-0.3.3.ebuild,v 1.1 2002/02/12 19:51:51 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Sierra script interpreter for your old Sierra adventures"
+SRC_URI="http://darmstadt.gmd.de/~jameson/${P}.tar.bz2"
+HOMEPAGE="http://freesci.linuxgames.com/"
+
+DEPEND="virtual/x11"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README.Unix THANKS TODO
+
+}
+
+