summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-05 11:43:09 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-05 11:43:09 +0000
commitcd7675eed5cf64c2c6792b132c8d8825dd96f44c (patch)
tree3e68601003403d8681772717edc87230e0e9fc7c /app-i18n/kde-i18n
parentadd new eclass kde-i18n.org for the new placement scheme used starting 3.0.2 ... (diff)
downloadhistorical-cd7675eed5cf64c2c6792b132c8d8825dd96f44c.tar.gz
historical-cd7675eed5cf64c2c6792b132c8d8825dd96f44c.tar.bz2
historical-cd7675eed5cf64c2c6792b132c8d8825dd96f44c.zip
kde 3.0.2 i18n packages
Diffstat (limited to 'app-i18n/kde-i18n')
-rw-r--r--app-i18n/kde-i18n/kde-i18n-3.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-i18n/kde-i18n/kde-i18n-3.0.2.ebuild b/app-i18n/kde-i18n/kde-i18n-3.0.2.ebuild
new file mode 100644
index 000000000000..844a7d926834
--- /dev/null
+++ b/app-i18n/kde-i18n/kde-i18n-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kde-i18n/kde-i18n-3.0.2.ebuild,v 1.1 2002/07/05 11:43:08 danarmak Exp $
+
+inherit kde-i18n
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.bz2
+
+ # we need to patch the Makefile.in's of <lang>/docs/common/ for each
+ # languager, but we can't patch Makefile.am's, so better than patching in
+ # src_compile, we make -f Makefile.cvs here in src_unpack.
+ cd ${S}
+ make -f Makefile.cvs
+ for x in `cat subdirs`; do
+ cd ${S}/${x}
+ [ -d docs/common ] && \
+ ( patch -p0 < ${DISTDIR}/kde-i18n-gentoo.patch || die )
+ done
+
+}