summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-04-21 16:38:20 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-04-21 16:38:20 +0000
commit7cc4b4c2009153d059aff9d107de3dad7cd6451c (patch)
treec267f00847cddd5bc57df0923439bce79ad642df /app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
parentinherit eutils too. (diff)
downloadhistorical-7cc4b4c2009153d059aff9d107de3dad7cd6451c.tar.gz
historical-7cc4b4c2009153d059aff9d107de3dad7cd6451c.tar.bz2
historical-7cc4b4c2009153d059aff9d107de3dad7cd6451c.zip
Version bumped, bug #218678.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild')
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
new file mode 100644
index 000000000000..01ed2d308167
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.3.1.ebuild,v 1.1 2008/04/21 16:38:20 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/29660/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk kde nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-7500 >=app-i18n/anthy-ss-7500 )
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2.8 )"
+RDEPEND="${DEPEND}
+ gtk? ( app-dicts/kasumi )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}