summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-24 12:47:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-24 12:47:57 +0000
commit50564f6db055b2ae65c5b2b4bd6f71156b6c24b4 (patch)
treec292439587a341eea7f5fa3c6537fd98e202af3b /app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild
parentVersion bump. Fixed parallel make failure #180988, thank Mike Doty for report... (diff)
downloadhistorical-50564f6db055b2ae65c5b2b4bd6f71156b6c24b4.tar.gz
historical-50564f6db055b2ae65c5b2b4bd6f71156b6c24b4.tar.bz2
historical-50564f6db055b2ae65c5b2b4bd6f71156b6c24b4.zip
Revert --without-arts, bug #235872.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild')
-rw-r--r--app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild b/app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..5ec046061849
--- /dev/null
+++ b/app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/scim-tables-0.5.8-r1.ebuild,v 1.1 2008/09/24 12:47:57 matsuu Exp $
+
+inherit kde-functions eutils base autotools
+
+DESCRIPTION="Smart Common Input Method (SCIM) Generic Table Input Method Server"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="kde nls"
+LANGS="am ar bn gu hi ja kn ko ml ne pa ru ta te th uk vi zh"
+for i in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+RDEPEND="x11-libs/libXt
+ >=app-i18n/scim-1.4.0
+ kde? ( >=app-i18n/skim-1.2.0 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}+gcc-4.3.patch
+)
+
+pkg_setup() {
+ if ! built_with_use '>=app-i18n/scim-1.4.0' gtk ; then
+ eerror ">=app-i18n/scim-1.4.0 with gtk USE flag is required by ${PF}."
+# die "Please reemerge >=app-i18n/scim-1.4.0 with USE=\"gtk\"."
+ fi
+
+ elog "Not all languages are going to be compiled."
+ elog "Please set LINGUAS to your preferred language(s)."
+ elog "Supported LINGUAS values are:"
+ elog "${LANGS}"
+}
+
+src_unpack() {
+ base_src_unpack
+
+ strip-linguas ${LANGS}
+ local use_languages="additional ${LINGUAS}"
+ elog "Languages being compiled are: ${use_languages}"
+
+ cd "${S}"
+ sed -i -e "/^SUBDIRS/s/.*/SUBDIRS = ${use_languages}/g" \
+ tables/Makefile.am || die "sed ${m} failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable kde skim-support) \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking \
+ --without-arts || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README ChangeLog AUTHORS
+}