summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-10-10 10:45:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-10-10 10:45:12 +0000
commit1a1f0edc7719e5320a234317e966d8e5fcf191e2 (patch)
tree063ad18e75218c145e5072f1ffeabf3adf5623d5 /app-i18n/scim/scim-1.4.5.ebuild
parentStable on Alpha + ia64, bug 138178. (diff)
downloadhistorical-1a1f0edc7719e5320a234317e966d8e5fcf191e2.tar.gz
historical-1a1f0edc7719e5320a234317e966d8e5fcf191e2.tar.bz2
historical-1a1f0edc7719e5320a234317e966d8e5fcf191e2.zip
Version bumped. Cleanup ebuild.
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'app-i18n/scim/scim-1.4.5.ebuild')
-rw-r--r--app-i18n/scim/scim-1.4.5.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/app-i18n/scim/scim-1.4.5.ebuild b/app-i18n/scim/scim-1.4.5.ebuild
new file mode 100644
index 000000000000..a20739c26faa
--- /dev/null
+++ b/app-i18n/scim/scim-1.4.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.5.ebuild,v 1.1 2006/10/10 10:45:11 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gtk kde qt3"
+
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ gtk? ( >=x11-libs/gtk+-2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ >=dev-libs/glib-2 )
+ !app-i18n/scim-cvs"
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )
+ doc? ( app-doc/doxygen )
+ dev-lang/perl
+ >=dev-util/intltool-0.33"
+
+PDEPEND="!alpha? ( !hppa? ( kde? ( app-i18n/skim ) ) )
+ !alpha? ( !hppa? ( !ppc64? ( !sparc? ( qt3? ( app-i18n/scim-qtimm ) ) ) ) )"
+
+get_gtk_confdir() {
+ if useq amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && useq x86 ) ; then
+ echo "/etc/gtk-2.0/${CHOST}"
+ else
+ echo "/etc/gtk-2.0"
+ fi
+}
+
+src_compile() {
+ # bug #83625
+ filter-flags -fvisibility-inlines-hidden
+ filter-flags -fvisibility=hidden
+
+ econf \
+ $(use_with doc doxygen) \
+ $(use_enable gtk panel-gtk) \
+ $(use_enable gtk setup-ui) \
+ $(use_enable gtk gtk2-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo "export GTK_IM_MODULE=\"scim\""
+ einfo "export QT_IM_MODULE=\"scim\""
+ einfo
+ einfo "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
+ einfo "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
+ einfo
+ einfo "If you prefer KDE/Qt interface, try emerge app-i18n/skim."
+ einfo
+ einfo "To use Chinese input methods:"
+ einfo " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
+ einfo "To use Korean input methods:"
+ einfo " # emerge app-i18n/scim-hangul"
+ einfo "To use Japanese input methods:"
+ einfo " # emerge app-i18n/scim-anthy"
+ einfo "To use various input methods (more than 30 languages):"
+ einfo " # emerge app-i18n/scim-m17n"
+ einfo
+ ewarn
+ ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
+ ewarn
+ epause 10
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+}
+
+pkg_postrm() {
+
+ [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > ${ROOT}$(get_gtk_confdir)/gtk.immodules
+}