summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2003-05-11 17:21:39 +0000
committerMasatomo Nakano <nakano@gentoo.org>2003-05-11 17:21:39 +0000
commit60935ba7977fb40e8ba24060bb9ee97b110f7182 (patch)
treed6a525f42744f3438fcbfae1a724eed2086694ae /app-i18n
parentfixed ebuild (added S) (diff)
downloadhistorical-60935ba7977fb40e8ba24060bb9ee97b110f7182.tar.gz
historical-60935ba7977fb40e8ba24060bb9ee97b110f7182.tar.bz2
historical-60935ba7977fb40e8ba24060bb9ee97b110f7182.zip
Version bump.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/canna/ChangeLog10
-rw-r--r--app-i18n/canna/canna-3.6_p3.ebuild41
-rw-r--r--app-i18n/canna/files/canna-3.6_p3-gentoo.diff346
-rw-r--r--app-i18n/canna/files/canna.initd13
-rw-r--r--app-i18n/canna/files/digest-canna-3.6_p31
5 files changed, 407 insertions, 4 deletions
diff --git a/app-i18n/canna/ChangeLog b/app-i18n/canna/ChangeLog
index 8404e491162c..8ac339cc1765 100644
--- a/app-i18n/canna/ChangeLog
+++ b/app-i18n/canna/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/canna
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/ChangeLog,v 1.12 2003/02/12 04:22:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/ChangeLog,v 1.13 2003/05/11 17:21:39 nakano Exp $
+
+*canna-3.6_p3 (11 May 2003)
+ 11 May 2003; Masatomo Nakano <nakano@gentoo.org> canna-3.6_p1.ebuild,
+ canna.initd,canna-3.6_p3-gentoo.diff:
+
+ Version bump. Thanks to Mamoru KOMACHI <usata@sodan.ecc.u-tokyo.ac.jp>
*canna-3.6-r1 (02 Dec 2002)
@@ -19,7 +25,7 @@
18 Nov 2002; Masatomo Nakano <nakano@gentoo.org> canna-3.6.ebuild :
Changed "~x86" to "x86".
-
+
16 Nov 2002; Masatomo Nakano <nakano@gentoo.org> canna-3.6.ebuild
files/canna-3.6-gentoo.diff files/canna.initd files/canna.confd
digest-canna-3.6 :
diff --git a/app-i18n/canna/canna-3.6_p3.ebuild b/app-i18n/canna/canna-3.6_p3.ebuild
new file mode 100644
index 000000000000..6ecfc2b06f9f
--- /dev/null
+++ b/app-i18n/canna/canna-3.6_p3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3.ebuild,v 1.1 2003/05/11 17:21:39 nakano Exp $
+
+MY_P="Canna36p3"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A client-server based Kana-Kanji conversion system"
+HOMEPAGE="http://canna.sourceforge.jp/"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc
+ x11-base/xfree"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ xmkmf || die
+ make Makefiles || die
+ # make includes
+ make canna || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install.man || die
+ dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/canna.initd canna || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/canna.confd canna || die
+ touch ${D}/var/log/canna/.keep || die
+}
+
diff --git a/app-i18n/canna/files/canna-3.6_p3-gentoo.diff b/app-i18n/canna/files/canna-3.6_p3-gentoo.diff
new file mode 100644
index 000000000000..03b80a9ae683
--- /dev/null
+++ b/app-i18n/canna/files/canna-3.6_p3-gentoo.diff
@@ -0,0 +1,346 @@
+diff -urN Canna36p3.ORIG/Canna.conf Canna36p3/Canna.conf
+--- Canna36p3.ORIG/Canna.conf 2003-01-25 17:47:47.000000000 +0900
++++ Canna36p3/Canna.conf 2003-05-05 19:48:58.000000000 +0900
+@@ -133,7 +133,7 @@
+ /* rootにならずにインストールする時はこれを定義して下さい */
+ /* #define InstallAsUser */
+ /* 従来と互換のディレクトリ構造にする場合はこれを定義してください */
+-#define ObsoleteInstallDir
++/* #define ObsoleteInstallDir */
+ #ifdef InstallAsUser
+ # define DefCannaPrefix $(HOME)/canna
+ # define DefErrDir $(cannaPrefix)/log
+@@ -144,7 +144,7 @@
+ # define DefErrDir /usr/spool/canna
+ # define DefLibCannaDir /usr/lib
+ # else
+-# define DefErrDir /var/log
++# define DefErrDir /var/log/canna
+ # define DefLibCannaDir $(cannaExecPrefix)/lib
+ # endif
+ #endif
+@@ -156,16 +156,18 @@
+ # define DefCannaLibDir $(cannaPrefix)/share/canna
+ #endif
+
+-cannaPrefix = DefCannaPrefix
++cannaPrefix = /usr
+ cannaExecPrefix = $(cannaPrefix)
+ cannaBinDir = $(cannaExecPrefix)/bin
+ cannaSrvDir = DefCannaSrvDir
+ XCOMM cannaLibDir = /var/lib/canna
+ XCOMM cannaLibDir = /var/db/canna
+ cannaLibDir = DefCannaLibDir
+-XCOMM cannaManDir = $(cannaPrefix)/share/man
+-cannaManDir = $(cannaPrefix)/man
++cannaManDir = $(cannaPrefix)/share/man
++XCOMM cannaManDir = $(cannaPrefix)/man
+ cannaIncDir = $(cannaPrefix)/include/canna
++cannaDocDir = $(cannaPrefix)/share/doc/canna-3.6_p3
++cannaShareDir = $(cannaPrefix)/share/canna
+
+ libCannaDir = DefLibCannaDir
+ ErrDir = DefErrDir
+@@ -248,7 +250,7 @@
+ /* #define UseInstalledLibCanna YES */
+ #define UseInstalledLibCanna NO
+
+-DicDir = $(cannaLibDir)/dic
++DicDir = /var/lib/canna/dic
+
+ #ifdef NeXT
+ #define NO_X_ENV
+@@ -561,6 +563,7 @@
+ echo "#define CANNAHOSTFILE '$(cannaLibDir)/cannahost'" >> junk @@\
+ echo "/* for lib/canna */" >> junk @@\
+ echo "#define CANNALIBDIR '$(cannaLibDir)'" >> junk @@\
++ echo "#define CANNASHAREDIR '$(cannaShareDir)'" >> junk @@\
+ echo "/* for scripts */" >> junk @@\
+ echo "#define CANNABINDIR $(cannaBinDir)" >> junk @@\
+ echo "/* others */" >> junk @@\
+@@ -587,6 +590,7 @@
+ echo "#define CANNAHOSTFILE \"$(cannaLibDir)/cannahost\"";\ @@\
+ echo "/* for lib/canna */";\ @@\
+ echo "#define CANNALIBDIR \"$(cannaLibDir)\""; \ @@\
++ echo "#define CANNASHAREDIR \"$(cannaShareDir)\""; \ @@\
+ echo "/* for scripts */";\ @@\
+ echo "#define CANNABINDIR $(cannaBinDir)"; \ @@\
+ echo "/* others */";\ @@\
+diff -urN Canna36p3.ORIG/cmd/catdic/Imakefile Canna36p3/cmd/catdic/Imakefile
+--- Canna36p3.ORIG/cmd/catdic/Imakefile 2002-12-28 11:52:40.000000000 +0900
++++ Canna36p3/cmd/catdic/Imakefile 2003-05-05 18:39:54.000000000 +0900
+@@ -1,6 +1,9 @@
+ /* $Id: Imakefile,v 1.2.2.3 2002/12/28 02:52:40 aida_s Exp $ */
+ #include "../../Canna.conf"
+
++/* gentoo: use hard links so that the image can be merged correctly */
++ LN = ln
++
+ CANNAROOT = ../..
+ CANNASRC = $(CANNAROOT)/lib/canna
+ RKCSRC = $(CANNAROOT)/lib/RKC
+diff -urN Canna36p3.ORIG/cmd/catdic/cannakill.man Canna36p3/cmd/catdic/cannakill.man
+--- Canna36p3.ORIG/cmd/catdic/cannakill.man 2002-10-23 00:19:13.000000000 +0900
++++ Canna36p3/cmd/catdic/cannakill.man 2003-05-05 18:41:06.000000000 +0900
+@@ -20,7 +20,7 @@
+ .\" PERFORMANCE OF THIS SOFTWARE.
+ .\"
+ .\" $Id: cannakill.man,v 1.2 2002/10/22 15:19:13 aida_s Exp $
+-.TH CANNAKILL 1M
++.TH CANNAKILL 1
+ .SH "NAME"
+ cannakill \- Terminate operation of the Kana-Kanji conversion server
+ cannaserver
+@@ -29,14 +29,14 @@
+ .SH "DESCRIPTION"
+ .PP
+ cannakill terminates operation of Kana-Kanji conversion server
+-cannaserver(1M). This causes the server to delete the socket and
++cannaserver(1). This causes the server to delete the socket and
+ close all open dictionaries before terminating its processing.
+ .PP
+-The user who has started cannaserver(1M) or the super user can only
+-use cannakill(1M) to terminate operation of canncannaer.
++The user who has started cannaserver(1) or the super user can only
++use cannakill(1) to terminate operation of canncannaer.
+ .SH "FILES"
+ .IP "@(UnixSockDir)/@(UnixSockName)[:num]" 36
+ Socket
+ .SH "SEE ALSO"
+ .PP
+-cannaserver(1M), cannastat(1), cannacheck(1)
++cannaserver(1), cannastat(1), cannacheck(1)
+diff -urN Canna36p3.ORIG/cmd/catdic/catdic.man Canna36p3/cmd/catdic/catdic.man
+--- Canna36p3.ORIG/cmd/catdic/catdic.man 2002-10-19 17:27:33.000000000 +0900
++++ Canna36p3/cmd/catdic/catdic.man 2003-05-05 18:41:39.000000000 +0900
+@@ -30,7 +30,7 @@
+ catdic downloads a dictionary file to the current directory.
+ The file downloaded is a dictionary file the dictionary name of which is
+ \fIremote-dic\fP. It is in the user dictionary directory of the machine
+-on which \fIcannaserver\fP(1M) is in operation. (Hereafter, this machine
++on which \fIcannaserver\fP(1) is in operation. (Hereafter, this machine
+ is called the remote host.)
+ .SH "OPTIONS"
+ .IP "\-cs \fIcanna-server\fP (or \-cannaserver \fIcanna-server\fP)" 12
+@@ -61,4 +61,4 @@
+ file ``test2.t''.
+ .SH "SEE ALSO"
+ .PP
+-cannaserver(1M), lsdic(1), mkdic(1)
++cannaserver(1), lsdic(1), mkdic(1)
+diff -urN Canna36p3.ORIG/cmd/catdic/mkdic.man Canna36p3/cmd/catdic/mkdic.man
+--- Canna36p3.ORIG/cmd/catdic/mkdic.man 2002-10-19 17:27:33.000000000 +0900
++++ Canna36p3/cmd/catdic/mkdic.man 2003-05-05 18:42:01.000000000 +0900
+@@ -28,7 +28,7 @@
+ .SH "DESCRIPTION"
+ .PP
+ mkdic creates user dictionary named \fIremote-dic\fP in the user dictionary
+-directory of the remote host, on which \fIcannaserver\fP(1M) is in operation.
++directory of the remote host, on which \fIcannaserver\fP(1) is in operation.
+ Dictionary file name \fIremote-dic\fP is assigned to this file at this time.
+ .PP
+ If the \- and \-l option isn't specified, mkdic creates an empty dictionary.
+@@ -96,4 +96,4 @@
+ user1.t is a dictionary file name generated automatically by the system.
+ .SH "SEE ALSO"
+ .PP
+-catdic(1), cannaserver(1M), lsdic(1)
++catdic(1), cannaserver(1), lsdic(1)
+diff -urN Canna36p3.ORIG/cmd/cshost/cshost.man Canna36p3/cmd/cshost/cshost.man
+--- Canna36p3.ORIG/cmd/cshost/cshost.man 2002-10-19 17:27:34.000000000 +0900
++++ Canna36p3/cmd/cshost/cshost.man 2003-05-05 18:42:29.000000000 +0900
+@@ -6,9 +6,9 @@
+ .SH "DESCRIPTION"
+ .PP
+ the \fIcshost\fP(1) prints the list of machines that are allowed to make
+-connections to \fIcannaserver\fP(1M).
++connections to \fIcannaserver\fP(1).
+ .PP
+-\fIcannaserver\fP(1M) allows network connections only from programs
++\fIcannaserver\fP(1) allows network connections only from programs
+ running on the same machine or machines listed in the file
+ /etc/hosts.canna. If /etc/hosts.canna does not exist or the file
+ is empty, access is granted to everyone.
+diff -urN Canna36p3.ORIG/dic/phono/Imakefile Canna36p3/dic/phono/Imakefile
+--- Canna36p3.ORIG/dic/phono/Imakefile 2002-10-19 17:27:40.000000000 +0900
++++ Canna36p3/dic/phono/Imakefile 2003-05-05 20:35:00.000000000 +0900
+@@ -27,9 +27,10 @@
+
+ ROMAJI_DIC_DEF = -DSHIFT
+
+- DICDIR = $(cannaLibDir)/dic
+- SAMPLEDIR = $(cannaLibDir)/sample
+- SAMPLESRCDIR = $(cannaLibDir)/sample/src
++ DICDIR = $(DicDir)
++ CANNASHAREDIR = $(cannaShareDir)
++ SAMPLEDIR = $(cannaDocDir)/sample
++ SAMPLESRCDIR = $(cannaDocDir)/sample/src
+
+ KPDEF = default.kpdef jdaemon.kpdef just.kpdef kaisoku.kpdef kana.kpdef \
+ lan5.kpdef matsu.kpdef newjis.kpdef romaji.kpdef sokuon.kpdef \
+@@ -69,7 +70,7 @@
+ MakeDirectories(install,$(DICDIR))
+ MakeDirectories(install,$(SAMPLESRCDIR))
+
+-InstallMultiple($(ROMKANA_TABLES),$(DICDIR))
++InstallMultiple($(ROMKANA_TABLES),$(CANNASHAREDIR))
+
+ #ifdef USE_OBSOLETE_STYLE_FILENAME
+ InstallNonExec(default.kpdef,$(SAMPLESRCDIR))
+diff -urN Canna36p3.ORIG/lib/canna/Imakefile Canna36p3/lib/canna/Imakefile
+--- Canna36p3.ORIG/lib/canna/Imakefile 2002-10-20 17:20:33.000000000 +0900
++++ Canna36p3/lib/canna/Imakefile 2003-05-05 18:45:37.000000000 +0900
+@@ -116,8 +116,8 @@
+ #endif /* ProjectX */
+ #endif /* DoSharedLib */
+
+-sglobal.h: GSYM.awk globnames
+- awk -f GSYM.awk < globnames > $@
++includes::
++ awk -f GSYM.awk < globnames > sglobal.h
+
+ clean::
+ $(RM) y.tab.h y.tab.c lex.yy.c gram.h gram.c lex.c sglobal.h
+diff -urN Canna36p3.ORIG/lib/canna/romaji.c Canna36p3/lib/canna/romaji.c
+--- Canna36p3.ORIG/lib/canna/romaji.c 2003-01-17 17:48:19.000000000 +0900
++++ Canna36p3/lib/canna/romaji.c 2003-05-05 19:17:15.000000000 +0900
+@@ -438,7 +438,7 @@
+ }
+ }
+
+-#if 0 /* currently CANNASHAREDDIR is not defined */
++#if 1 /* currently CANNASHAREDDIR is defined */
+ if (retval == (struct RkRxDic *)NULL) { /* added for Debian by ISHIKAWA Mutsumi <ishikawa@linux.or.jp> */
+ extern jrUserInfoStruct *uinfo;
+
+diff -urN Canna36p3.ORIG/misc/Imakefile Canna36p3/misc/Imakefile
+--- Canna36p3.ORIG/misc/Imakefile 2003-01-13 14:34:30.000000000 +0900
++++ Canna36p3/misc/Imakefile 2003-05-05 19:19:27.000000000 +0900
+@@ -34,14 +34,14 @@
+ MakeLintLibSubdirs($(SUBDIRS))
+ MakeLintSubdirs($(SUBDIRS),install.ln,install.ln)
+
+-MakeDirectories(install,$(cannaLibDir)/sample/src)
++MakeDirectories(install,$(cannaDocDir)/sample/src)
+ #if defined(nec_ews_svr4) || defined(pcux_r32)
+-InstallNamedNonExec(rMakefile,Makefile,$(cannaLibDir)/sample/src)
++InstallNamedNonExec(rMakefile,Makefile,$(cannaDocDir)/sample/src)
+ #else
+-InstallNamedNonExec(cMakefile,Makefile,$(cannaLibDir)/sample/src)
++InstallNamedNonExec(cMakefile,Makefile,$(cannaDocDir)/sample/src)
+ #endif /* nec_ews_svr4 */
+
+-InstallNonExec(is.c,$(cannaLibDir)/sample/src)
++InstallNonExec(is.c,$(cannaDocDir)/sample/src)
+
+ clean::
+ $(RM) $(PROGRAMS)
+diff -urN Canna36p3.ORIG/misc/initfiles/Imakefile Canna36p3/misc/initfiles/Imakefile
+--- Canna36p3.ORIG/misc/initfiles/Imakefile 2003-01-21 19:57:03.000000000 +0900
++++ Canna36p3/misc/initfiles/Imakefile 2003-05-05 19:21:20.000000000 +0900
+@@ -6,7 +6,7 @@
+ #endif
+
+ CANNAROOT = ../..
+- SAMPLEDIR = $(cannaLibDir)/sample
++ SAMPLEDIR = $(cannaShareDir)
+
+ all::
+
+@@ -22,7 +22,7 @@
+ Install: 1.1.cob 1.2.cob fixer.cob jdemon.cob just.cob lan5.cob modes.cob \
+ matsu.cob sample.cob skk.cob tut.cob unix.cob vje.cob wx2+.cob \
+ default.cob
+-InstallNamedNonExec(default.cob,default.canna,$(cannaLibDir))
++InstallNamedNonExec(default.cob,default.canna,$(cannaShareDir))
+ InstallNamedNonExec(1.1.cob,1.1.canna,$(SAMPLEDIR))
+ InstallNamedNonExec(1.2.cob,1.2.canna,$(SAMPLEDIR))
+ InstallNamedNonExec(fixer.cob,fixer.canna,$(SAMPLEDIR))
+@@ -38,7 +38,7 @@
+ InstallNamedNonExec(vje.cob,vje.canna,$(SAMPLEDIR))
+ InstallNamedNonExec(wx2+.cob,wx2+.canna,$(SAMPLEDIR))
+ #else
+-InstallNamedNonExec(default.ca,default.canna,$(cannaLibDir))
++InstallNamedNonExec(default.ca,default.canna,$(cannaShareDir))
+ InstallNonExec(1.1.canna,$(SAMPLEDIR))
+ InstallNonExec(1.2.canna,$(SAMPLEDIR))
+ InstallNonExec(fixer.canna,$(SAMPLEDIR))
+diff -urN Canna36p3.ORIG/server/server.man Canna36p3/server/server.man
+--- Canna36p3.ORIG/server/server.man 2002-11-01 17:32:06.000000000 +0900
++++ Canna36p3/server/server.man 2003-05-05 19:21:54.000000000 +0900
+@@ -20,7 +20,7 @@
+ .\" PERFORMANCE OF THIS SOFTWARE.
+ .\"
+ .\" $Id: server.man,v 1.6 2002/11/01 08:32:06 zu2 Exp $
+-.TH CANNASERVER 1M
++.TH CANNASERVER 1
+ .SH "NAME"
+ cannaserver \- Kana-Kanji conversion server
+ .SH "SYNOPSIS"
+@@ -28,19 +28,19 @@
+ .SH "DESCRIPTION"
+ .PP
+ cannaserver provides the Kana-Kanji conversion service. Usually all
+-users on the network can access cannaserver(1M). The scope of
++users on the network can access cannaserver(1). The scope of
+ accessing sources (hosts, users) can be restricted using the
+ /etc/hosts.canna file.
+ .PP
+-After starting, cannaserver(1M) immediately forks and enters the
++After starting, cannaserver(1) immediately forks and enters the
+ background process. Thus, you do not need to use '&' to set the
+ background process explicitly.
+ .PP
+-When starting, cannaserver(1M) creates the UNIX domain socket
++When starting, cannaserver(1) creates the UNIX domain socket
+ @(UnixSockDir)/@(UnixSockName) to communicate clients. The
+-socket is deleted automatically at the end of cannaserver(1M) if no
+-trouble occurs. The socket may exist although cannaserver(1M) is
+-not in operation (because cannaserver(1M) terminates abnormally, for
++socket is deleted automatically at the end of cannaserver(1) if no
++trouble occurs. The socket may exist although cannaserver(1) is
++not in operation (because cannaserver(1) terminates abnormally, for
+ example). In this case, delete the file manually.
+ .PP
+ Specification of the dictionary to use is determined by referencing
+@@ -50,25 +50,25 @@
+ .IP "\fIddpath\fP" 12
+ Specifies the directory that contains the dictionary.
+ .IP "\-inet" 12
+-The remote host can connect with the cannaserver(1M) using
++The remote host can connect with the cannaserver(1) using
+ the inet domain socket.
+-By the default, the cannaserver(1M) uses only UNIX domain socket.
++By the default, the cannaserver(1) uses only UNIX domain socket.
+ i.e. Only clients in your local machine can connect to the server.
+ .IP "\-l \fIn\fP" 12
+-Outputs the cannaserver(1M) log to /tmp/canna.log. n (1 to 5)
++Outputs the cannaserver(1) log to /tmp/canna.log. n (1 to 5)
+ specifies the log level.
+ .IP "\-d" 12
+-Starts cannaserver(1M) in debug mode. It is executed as the
++Starts cannaserver(1) in debug mode. It is executed as the
+ foreground process. Log data at log level 5 is output to the standard
+ output.
+ .IP "\-u \fIuserid\fP" 12
+-Specifies which user cannaserver(1M) runs as. By default, cannaserver(1M)
+-runs as the user who started cannaserver(1M).
++Specifies which user cannaserver(1) runs as. By default, cannaserver(1)
++runs as the user who started cannaserver(1).
+ .IP "\-syslog" 12
+-Outputs the cannaserver(1M) log to syslogd(8).
++Outputs the cannaserver(1) log to syslogd(8).
+ .IP "\-p \fInum\fP" 12
+-If specified, cannaserver(1M) will use the port number 5680 + num. By
+-default, cannaserver(1M) uses the port number 5680.
++If specified, cannaserver(1) will use the port number 5680 + num. By
++default, cannaserver(1) uses the port number 5680.
+ .SH "FILES"
+ .IP "@(UnixSockDir)/@(UnixSockName)[:num]" 36
+ Socket
+@@ -78,4 +78,4 @@
+ Access control file
+ .SH "SEE ALSO"
+ .PP
+-cannakill(1M), cannastat(1), cannacheck(1)
++cannakill(1), cannastat(1), cannacheck(1)
diff --git a/app-i18n/canna/files/canna.initd b/app-i18n/canna/files/canna.initd
index cb53ce5fda46..e84759f0ec27 100644
--- a/app-i18n/canna/files/canna.initd
+++ b/app-i18n/canna/files/canna.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/app-misc/canna/files/3.5_beta2/canna
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/files/canna.initd,v 1.3 2003/05/11 17:21:39 nakano Exp $
# CANNASERVER_OPTS is defined in /etc/conf.d/canna
@@ -12,8 +12,17 @@ start() {
}
stop() {
+ if [ -x /usr/sbin/cannakill ]; then
+ CANNAKILL="/usr/sbin/cannakill"
+ elif [ -x /usr/bin/cannakill ]; then
+ CANNAKILL="/usr/bin/cannakill"
+ else
+ eerror "file not found: cannakill"
+ return 1
+ fi
+
ebegin "Stopping canna"
- /usr/bin/cannakill
+ ${CANNAKILL}
eend $? "Failed to stop canna"
}
diff --git a/app-i18n/canna/files/digest-canna-3.6_p3 b/app-i18n/canna/files/digest-canna-3.6_p3
new file mode 100644
index 000000000000..a69e983ff335
--- /dev/null
+++ b/app-i18n/canna/files/digest-canna-3.6_p3
@@ -0,0 +1 @@
+MD5 fc48790adccd026aa2b1ddba80fe5850 Canna36p3.tar.gz 1441598