summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-31 14:56:01 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-31 14:56:01 +0000
commitd01b015049fcb3b415e9fa56107da3dfe5da75d6 (patch)
tree3bd97503d162d38ad688d4226d48384a26fcef45 /app-i18n
parentRemove empty stray .directory directories. (diff)
downloadhistorical-d01b015049fcb3b415e9fa56107da3dfe5da75d6.tar.gz
historical-d01b015049fcb3b415e9fa56107da3dfe5da75d6.tar.bz2
historical-d01b015049fcb3b415e9fa56107da3dfe5da75d6.zip
Fixed as-needed issue, bug #298744.
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/freewnn/ChangeLog11
-rw-r--r--app-i18n/freewnn/files/freewnn-1.1.1_alpha21-as-needed.patch11
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha21-r1.ebuild54
-rw-r--r--app-i18n/im-freewnn/ChangeLog10
-rw-r--r--app-i18n/im-freewnn/files/im-freewnn-0.0.2-as-needed.patch35
-rw-r--r--app-i18n/im-freewnn/im-freewnn-0.0.2-r1.ebuild47
6 files changed, 164 insertions, 4 deletions
diff --git a/app-i18n/freewnn/ChangeLog b/app-i18n/freewnn/ChangeLog
index a9fb8cd67e29..f819f1213aef 100644
--- a/app-i18n/freewnn/ChangeLog
+++ b/app-i18n/freewnn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/freewnn
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/ChangeLog,v 1.35 2007/07/12 13:04:22 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/ChangeLog,v 1.36 2009/12/31 14:54:59 matsuu Exp $
+
+*freewnn-1.1.1_alpha21-r1 (31 Dec 2009)
+
+ 31 Dec 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +freewnn-1.1.1_alpha21-r1.ebuild,
+ +files/freewnn-1.1.1_alpha21-as-needed.patch:
+ Fixed as-needed issue, bug #298744.
12 Jul 2007; Raúl Porcel <armin76@gentoo.org>
freewnn-1.1.1_alpha21.ebuild:
diff --git a/app-i18n/freewnn/files/freewnn-1.1.1_alpha21-as-needed.patch b/app-i18n/freewnn/files/freewnn-1.1.1_alpha21-as-needed.patch
new file mode 100644
index 000000000000..588c28731db7
--- /dev/null
+++ b/app-i18n/freewnn/files/freewnn-1.1.1_alpha21-as-needed.patch
@@ -0,0 +1,11 @@
+--- FreeWnn-1.1.1-a021.orig/Wnn/jlib/Makefile.in 2004-09-12 18:56:55.000000000 +0200
++++ FreeWnn-1.1.1-a021/Wnn/jlib/Makefile.in 2009-12-29 20:29:18.086539501 +0100
+@@ -101,7 +101,7 @@
+ all:: libwnn.la
+
+ libwnn.la: $(OBJS) $(EXTRALIBRARYDEPS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS:.o=.lo) -rpath $(WNNLIBDIR) -version-info $(WNNJLIBVERSION)
++ $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJS:.o=.lo) @LIBS@ -rpath $(WNNLIBDIR) -version-info $(WNNJLIBVERSION)
+
+ lintlib:: llib-lwnn.ln
+
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha21-r1.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha21-r1.ebuild
new file mode 100644
index 000000000000..db75de669bc0
--- /dev/null
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha21-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha21-r1.ebuild,v 1.1 2009/12/31 14:54:59 matsuu Exp $
+
+inherit eutils
+
+MY_P="FreeWnn-${PV/_alpha/-a0}"
+
+DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
+HOMEPAGE="http://freewnn.sourceforge.jp/
+ http://www.freewnn.org/"
+SRC_URI="mirror://sourceforge.jp/freewnn/17724/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X ipv6"
+
+DEPEND="X? ( x11-libs/libX11 x11-libs/libXmu x11-libs/libXt )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ #Change WNNOWNER to root so we don't need to add wnn user
+ sed -i -e "s/WNNOWNER = wnn/WNNOWNER = root/" makerule.mk.in || die
+ # bug #298744
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+}
+
+src_compile() {
+ econf \
+ --disable-cWnn \
+ --disable-kWnn \
+ --without-termcap \
+ $(use_with X x) \
+ $(use_with ipv6) \
+ || die "./configure failed"
+ emake -j1 || die
+}
+
+src_install() {
+ # install executables, libs ,dictionaries
+ emake DESTDIR="${D}" install || die "installation failed"
+ # install man pages
+ emake DESTDIR="${D}" install.man || die "installation of manpages failed"
+ # install docs
+ dodoc ChangeLog* CONTRIBUTORS
+ # install rc script
+ newinitd "${FILESDIR}"/freewnn.initd freewnn
+}
diff --git a/app-i18n/im-freewnn/ChangeLog b/app-i18n/im-freewnn/ChangeLog
index 130bb5a48eb6..588e40c9f10b 100644
--- a/app-i18n/im-freewnn/ChangeLog
+++ b/app-i18n/im-freewnn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/im-freewnn
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-freewnn/ChangeLog,v 1.8 2007/04/22 10:37:44 corsair Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-freewnn/ChangeLog,v 1.9 2009/12/31 14:56:00 matsuu Exp $
+
+*im-freewnn-0.0.2-r1 (31 Dec 2009)
+
+ 31 Dec 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +im-freewnn-0.0.2-r1.ebuild, +files/im-freewnn-0.0.2-as-needed.patch:
+ Fixed as-needed issue, bug #298744.
22 Apr 2007; Markus Rothe <corsair@gentoo.org> im-freewnn-0.0.2.ebuild:
Added ~ppc64
diff --git a/app-i18n/im-freewnn/files/im-freewnn-0.0.2-as-needed.patch b/app-i18n/im-freewnn/files/im-freewnn-0.0.2-as-needed.patch
new file mode 100644
index 000000000000..859ea779817a
--- /dev/null
+++ b/app-i18n/im-freewnn/files/im-freewnn-0.0.2-as-needed.patch
@@ -0,0 +1,35 @@
+--- im-freewnn-0.0.2.orig/Makefile.am 2004-08-04 07:05:06.000000000 +0200
++++ im-freewnn-0.0.2/Makefile.am 2009-12-29 20:34:54.420539767 +0100
+@@ -10,8 +10,6 @@
+
+ DEPS =
+
+-LDADDS = @GTK_DEP_LIBS@ -lcrypt
+-
+ EXTRA_DIST= \
+ im-freewnn.spec
+
+@@ -38,7 +36,7 @@
+ candwin.h \
+ candwin.c
+
+-im_freewnn_la_LIBADD = $(LDADDS) -lcrypt
++im_freewnn_la_LIBADD = @LIBS@ @GTK_DEP_LIBS@ -lcrypt
+
+ module_LTLIBRARIES = \
+ im-freewnn.la
+--- im-freewnn-0.0.2.orig/configure.in 2004-08-05 08:04:36.000000000 +0200
++++ im-freewnn-0.0.2/configure.in 2009-12-29 20:36:31.562539161 +0100
+@@ -48,11 +48,8 @@
+ AM_CONDITIONAL(PLATFORM_WIN32, test "$platform_win32" = "yes")
+
+ dnl FreeWnn check
+-ldflags_backup="$LDFLAGS"
+-LDFLAGS="$LDFLAGS -lcrypt"
+ AC_CHECK_HEADER(wnn/jlib.h,,)
+-AC_CHECK_LIB(wnn, jl_open_lang,,)
+-LDFLAGS="$ldflags_backup"
++AC_CHECK_LIB([wnn], [jl_open_lang], , ,[-lcrypt])
+
+ AC_OUTPUT([
+ Makefile
diff --git a/app-i18n/im-freewnn/im-freewnn-0.0.2-r1.ebuild b/app-i18n/im-freewnn/im-freewnn-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..88d8b91bffe4
--- /dev/null
+++ b/app-i18n/im-freewnn/im-freewnn-0.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/im-freewnn/im-freewnn-0.0.2-r1.ebuild,v 1.1 2009/12/31 14:56:00 matsuu Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Japanese FreeWnn input method module for GTK+2"
+HOMEPAGE="http://bonobo.gnome.gr.jp/~nakai/immodule/"
+SRC_URI="http://bonobo.gnome.gr.jp/~nakai/immodule/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=app-i18n/freewnn-1.1.1_alpha21-r1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-wnnrc-gentoo.diff"
+ # bug #298744
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+}
+
+pkg_postrm() {
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+}