summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-11 07:41:08 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-11 07:41:08 +0000
commitf048742f0e899a3eaf01c8d9db35b719b2955a6f (patch)
tree5ad48e6ce09c402936f0fcee7314bcba985f2e98 /app-i18n
parentNew snapshot version. Added auxilarly Cannadic support. (diff)
downloadhistorical-f048742f0e899a3eaf01c8d9db35b719b2955a6f.tar.gz
historical-f048742f0e899a3eaf01c8d9db35b719b2955a6f.tar.bz2
historical-f048742f0e899a3eaf01c8d9db35b719b2955a6f.zip
New snapshot version. Added auxilarly Cannadic support.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy/Manifest6
-rw-r--r--app-i18n/anthy/anthy-4507.ebuild80
-rw-r--r--app-i18n/anthy/files/digest-anthy-45071
-rw-r--r--app-i18n/anthy/metadata.xml8
4 files changed, 92 insertions, 3 deletions
diff --git a/app-i18n/anthy/Manifest b/app-i18n/anthy/Manifest
index 04689277bbbb..b4cbec9421d5 100644
--- a/app-i18n/anthy/Manifest
+++ b/app-i18n/anthy/Manifest
@@ -1,7 +1,7 @@
MD5 c8705914e6d4b55d82ea00b4b299cc19 anthy-4300b.ebuild 1041
-MD5 8fb759b746661a0734409d56ec7e3618 metadata.xml 540
-MD5 ceb3f9b014d8a65bd5f01f872de596e5 ChangeLog 973
-MD5 93d17af37f367a144cf540d00a9facc7 anthy-4507.ebuild 1915
+MD5 110027f473a759d42095c0b178b41f19 metadata.xml 846
+MD5 e23da04c0aec2ae9106356fd0fd433ef ChangeLog 1246
+MD5 e0706dfec1d68fe10ce43438e4a4407a anthy-4507.ebuild 1915
MD5 83e271d277525e627be3756f01c7010e files/digest-anthy-4300b 64
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 7bbcd511928477630332c6bd34c6e528 files/digest-anthy-4507 63
diff --git a/app-i18n/anthy/anthy-4507.ebuild b/app-i18n/anthy/anthy-4507.ebuild
new file mode 100644
index 000000000000..e0ea8d7cb199
--- /dev/null
+++ b/app-i18n/anthy/anthy-4507.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4507.ebuild,v 1.1 2003/09/11 07:41:05 usata Exp $
+
+IUSE="emacs"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/5847/${P}.tar.gz"
+
+# This branch, so-called anthy-ss (snapshot) is a development branch,
+# so it is not intended to be marked as stable. It will remain unstable
+# all the time unless there comes another -ss branch.
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ app-dicts/canna-cannadic"
+RDEPEND="virtual/glibc
+ emacs? ( virtual/emacs )"
+
+SITEFILE="50anthy-gentoo.el"
+SITELISP=/usr/share/emacs/site-lisp
+
+src_compile() {
+
+ local myconf cannadicdir
+ cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs \
+ || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode' ; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+ if has_version 'app-dicts/canna-2ch' ; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} --with-cannadic=${cannadicdir} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ if [ -n "` use emacs`" ] ; then
+ insinto ${SITELISP}
+ doins ${FILESDIR}/${SITEFILE}
+ fi
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+}
+
+pkg_postinst() {
+
+ if [ -n "` use emacs`" ] ; then
+ inherit elisp
+ elisp-site-regen
+ fi
+}
+
+pkg_postrm() {
+
+ if [ -n "` use emacs`" ] ; then
+ inherit elisp
+ elisp-site-regen
+ fi
+}
diff --git a/app-i18n/anthy/files/digest-anthy-4507 b/app-i18n/anthy/files/digest-anthy-4507
new file mode 100644
index 000000000000..31f6da7bb2f4
--- /dev/null
+++ b/app-i18n/anthy/files/digest-anthy-4507
@@ -0,0 +1 @@
+MD5 f63971311c6be17464a8b2983042972d anthy-4507.tar.gz 1413032
diff --git a/app-i18n/anthy/metadata.xml b/app-i18n/anthy/metadata.xml
index bfdbd2e80b35..c7a9485e582d 100644
--- a/app-i18n/anthy/metadata.xml
+++ b/app-i18n/anthy/metadata.xml
@@ -3,6 +3,14 @@
<pkgmetadata>
<herd>cjk</herd>
<herd>emacs</herd>
+<maintainer>
+ <email>usata@gentoo.org</email>
+ <name>Mamoru KOMACHI</name>
+ <description>I created the ebuild to test app-i18n/uim but I'm not a
+ full Anthy user at the moment, so I'd like someone to help testing
+ and managing these ebuilds (especially anthy-ss stuff).
+ </description>
+</maintainer>
<longdescription>
Anthy is a free and secure Japanese kana-kanji server. This ebuild
includes cannadic as a server-side dictionary, so you don't need any