summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-09-08 00:04:25 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-09-08 00:04:25 +0000
commitf48cdffbc88dd92785190608d3f3728533bace5f (patch)
treef0f1e55c709bd3a261eb5c17af04ca6b6c0a756b /app-i18n
parentVersion bumped. (diff)
downloadhistorical-f48cdffbc88dd92785190608d3f3728533bace5f.tar.gz
historical-f48cdffbc88dd92785190608d3f3728533bace5f.tar.bz2
historical-f48cdffbc88dd92785190608d3f3728533bace5f.zip
Version bumped. Fixed dependency.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090907.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 327877473336..cfa30d354f4b 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.12 2009/08/13 14:50:43 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.13 2009/09/08 00:04:25 matsuu Exp $
+
+*ibus-anthy-1.2.0.20090907 (08 Sep 2009)
+
+ 08 Sep 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.2.0.20090907.ebuild:
+ Version bumped. Fixed dependency.
*ibus-anthy-1.2.0.20090813 (13 Aug 2009)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090907.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090907.ebuild
new file mode 100644
index 000000000000..11d81ede81b0
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090907.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.2.0.20090907.ebuild,v 1.1 2009/09/08 00:04:25 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20090904
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}