summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-07-07 23:44:45 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-07-07 23:44:45 +0000
commit1a510d46fa5677c0eacb36f87b2315ccef955bbc (patch)
tree3adcee67bc63dadbd62ffb9fc43daaad2133b595 /app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild
parentNew release. (diff)
downloadhistorical-1a510d46fa5677c0eacb36f87b2315ccef955bbc.tar.gz
historical-1a510d46fa5677c0eacb36f87b2315ccef955bbc.tar.bz2
historical-1a510d46fa5677c0eacb36f87b2315ccef955bbc.zip
New release, fixes daemon issues.
Package-Manager: portage-2.1.3_rc6
Diffstat (limited to 'app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild')
-rw-r--r--app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild b/app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild
new file mode 100644
index 000000000000..030ce6630900
--- /dev/null
+++ b/app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/gtkpbbuttons/gtkpbbuttons-0.6.10.ebuild,v 1.1 2007/07/07 23:44:45 josejx Exp $
+
+inherit eutils
+
+DESCRIPTION="On screen display client for pbbuttonsd"
+HOMEPAGE="http://pbbuttons.sf.net"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="gnome"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ >=media-libs/audiofile-0.1.9
+ dev-libs/popt
+ >=app-laptop/pbbuttonsd-0.7.9
+ gnome? ( gnome-base/libgnomeui )"
+
+src_compile() {
+ myconf=""
+ use gnome && myconf="${myconf} --with-gnome"
+ econf ${myconf} || die "Configuration failed"
+ make || die "Compile failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc README
+}