summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-02 20:42:11 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-02 20:42:11 +0000
commit26f74319fc6deb24ba78866ea4b3e5393f86ea56 (patch)
tree7f45ae92441bb250b160ee7dae8c38398b045a4e /app-misc/digitemp/digitemp-3.3.1.ebuild
parentAdded support for xinerama flag. Thanks to James Le Cuirot <chewi@ffaura.com>... (diff)
downloadhistorical-26f74319fc6deb24ba78866ea4b3e5393f86ea56.tar.gz
historical-26f74319fc6deb24ba78866ea4b3e5393f86ea56.tar.bz2
historical-26f74319fc6deb24ba78866ea4b3e5393f86ea56.zip
Version bumped. Closes 39946
Diffstat (limited to 'app-misc/digitemp/digitemp-3.3.1.ebuild')
-rw-r--r--app-misc/digitemp/digitemp-3.3.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/digitemp/digitemp-3.3.1.ebuild b/app-misc/digitemp/digitemp-3.3.1.ebuild
new file mode 100644
index 000000000000..b359b19b6567
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.3.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.3.1.ebuild,v 1.1 2004/02/02 20:42:11 mholzer Exp $
+
+IUSE="perl python"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # default is to compile to the ds9097u. local use flag takes care of
+ # passive ds9097. the ds9097u setting is what i have, so probably a safe
+ # default - nothing special here.
+ local target="ds9097u"
+ [ "${SERIAL_DRIVER}" = ds9097 ] && target="ds9097"
+ make clean
+
+ ewarn ""
+ ewarn "making for ${target} serial controller. if you would like support"
+ ewarn "for another controller, please set SERIAL_DRIVER=\"ds9097u\" or"
+ ewarn "SERIAL_DRIVER=\"ds9097\" as appropriate"
+ ewarn ""
+
+ make ${target}
+}
+
+src_install() {
+ dobin digitemp
+ dodoc README COPYING FAQ TODO
+
+ # method one: don't treat the examples as docs; place them somewhere else.
+ # then tell the user where to find this stuff. suitable alternative:
+ # specify exampledir="/usr/share/doc/${PF}"
+
+ local exampledir="/usr/share/${PN}"
+ local perldir="${exampledir}/perl_examples"
+ insinto ${perldir}
+ doins perl/*
+ local pythondir="${exampledir}/python_examples"
+ insinto ${pythondir}
+ doins python/*
+ local rrdbdir="${exampledir}/rrdb_examples"
+ insinto ${rrdbdir}
+ doins rrdb/*
+}
+
+pkg_postinst() {
+ ewarn "set the SERIAL_DRIVER environment variable to ds9097 to build"
+ ewarn "for that controller instead"
+ einfo ""
+ einfo "examples of using digitemp with python, perl, and rrdtool are"
+ einfo "located in ${exampledir}"
+ einfo ""
+}