summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-10-07 05:22:19 +0000
committerBrad Laue <brad@gentoo.org>2004-10-07 05:22:19 +0000
commit300eb79049689297b3ef18474065ece3af803ad1 (patch)
treeef1e86bd3a07907a8b0d150c5dc052202a250517 /app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild
parentmask gettext-0.14.1 #66449 (diff)
downloadhistorical-300eb79049689297b3ef18474065ece3af803ad1.tar.gz
historical-300eb79049689297b3ef18474065ece3af803ad1.tar.bz2
historical-300eb79049689297b3ef18474065ece3af803ad1.zip
Remove the locale check entirely
Diffstat (limited to 'app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild')
-rw-r--r--app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild b/app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild
new file mode 100644
index 000000000000..34f3ff394ce2
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/emelfm2-0.0.9-r1.ebuild,v 1.1 2004/10/07 05:22:19 brad Exp $
+
+inherit eutils
+
+DESCRIPTION="A file manager that implements the popular two-pane design based on gtk+-2"
+HOMEPAGE="http://dasui.prima.de/e2wiki/"
+SRC_URI="http://dasui.prima.de/~tooar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls"
+
+DEPEND=">=x11-libs/gtk+-2.4*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/locale.patch
+}
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="-DENABLE_NLS"
+ emake PREFIX=/usr \
+ CC="gcc ${CFLAGS}" \
+ NLS=${myconf} || die "emake failed"
+}
+
+src_install() {
+ local myconf
+
+ use nls && myconf="-DENABLE_NLS"
+ dodir /usr/bin
+
+ make PREFIX=${D}/usr \
+ NLS=${myconf} \
+ DOC_DIR=${D}/usr/share/doc/${PF} \
+ install || die "make install failed"
+ prepalldocs
+}