summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-28 06:32:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-28 06:32:55 +0000
commit84091028ae002aa7b163263cdd877fe65c3efdfd (patch)
tree61ec4c3f1d6751a19a717bd7c261f3304360a1e4 /app-misc/jpilot
parentAdded -Wno-deprecate to CPPFLAGS to support gcc3.1 (diff)
downloadhistorical-84091028ae002aa7b163263cdd877fe65c3efdfd.tar.gz
historical-84091028ae002aa7b163263cdd877fe65c3efdfd.tar.bz2
historical-84091028ae002aa7b163263cdd877fe65c3efdfd.zip
updated syncmal version in the ebuild to compile against newer pilot-link
Diffstat (limited to 'app-misc/jpilot')
-rw-r--r--app-misc/jpilot/ChangeLog13
-rw-r--r--app-misc/jpilot/files/digest-jpilot-0.99-r23
-rw-r--r--app-misc/jpilot/files/digest-jpilot-0.99.2-r13
-rw-r--r--app-misc/jpilot/jpilot-0.99-r2.ebuild66
-rw-r--r--app-misc/jpilot/jpilot-0.99.2-r1.ebuild69
5 files changed, 84 insertions, 70 deletions
diff --git a/app-misc/jpilot/ChangeLog b/app-misc/jpilot/ChangeLog
index 22068964f319..248392dd538c 100644
--- a/app-misc/jpilot/ChangeLog
+++ b/app-misc/jpilot/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-misc/jpilot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/ChangeLog,v 1.2 2002/02/12 21:20:16 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/ChangeLog,v 1.3 2002/05/28 06:32:55 seemant Exp $
+
+*jpilot-0.99.2-r1 (27 May 2002)
+
+ 27 May 2002; Seemant Kulleen <seemant@gentoo.org> jpilot-0.99.2-r1.ebuild
+ files/digest-jpilot-0.99.2-r1 :
+
+ Recenly I updated the pilot-link and gnome-pilot and gnome-pilot-link
+ packages. As a result, the syncmal plugin for the jpilot package broke.
+ Upon closer investigation, it turned out the syncmal-plugin itself has an
+ updated version. So, this revision differs only by the version number of
+ the syncmal plugin.
*jpilot-0.99.2 (12 Feb 2002)
diff --git a/app-misc/jpilot/files/digest-jpilot-0.99-r2 b/app-misc/jpilot/files/digest-jpilot-0.99-r2
deleted file mode 100644
index f197da205fd5..000000000000
--- a/app-misc/jpilot/files/digest-jpilot-0.99-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a6c8c1a9bc74f8a3f8403c451fdaef0f jpilot-0.99.tar.gz 488619
-MD5 b2a64720dc4c6e33d2b247c2d53700e4 malsync_2.0.6.src.tar.gz 387914
-MD5 61f5c38dad01977a1e3d70e4cdee7e7d jpilot-syncmal_0.62.tar.gz 125450
diff --git a/app-misc/jpilot/files/digest-jpilot-0.99.2-r1 b/app-misc/jpilot/files/digest-jpilot-0.99.2-r1
new file mode 100644
index 000000000000..d32b111419cb
--- /dev/null
+++ b/app-misc/jpilot/files/digest-jpilot-0.99.2-r1
@@ -0,0 +1,3 @@
+MD5 57be9e7cd2b2878fd439c98d77d4bdb9 jpilot-0.99.2.tar.gz 864763
+MD5 962702319e49618b2dced101572b41e8 malsync_2.0.7.src.tar.gz 173957
+MD5 754e8dd3f6614cfc68d637ae62f88851 jpilot-syncmal_0.71.tar.gz 302724
diff --git a/app-misc/jpilot/jpilot-0.99-r2.ebuild b/app-misc/jpilot/jpilot-0.99-r2.ebuild
deleted file mode 100644
index dfc5349691c4..000000000000
--- a/app-misc/jpilot/jpilot-0.99-r2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Bruce A. Locke <blocke@shivan.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99-r2.ebuild,v 1.3 2002/05/23 06:50:09 seemant Exp $
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
-SRC_URI="http://jpilot.org/${P}.tar.gz
-http://www.tomw.org/malsync/malsync_2.0.6.src.tar.gz
-http://people.atl.mediaone.net/jasonday/code/syncmal/jpilot-syncmal_0.62.tar.gz"
-HOMEPAGE="http://jpilot.org/"
-# In order to use the malsync plugin you'll need to refer to the homepage
-# for jpilot-syncmal http://people.atl.mediaone.net/jasonday/code/syncmal/
-# And you'll also need an avangto account.
-
-DEPEND="=x11-libs/gtk+-1.2* >=dev-libs/pilot-link-0.9.5"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- unpack jpilot-syncmal_0.62.tar.gz
- cd ${S}/jpilot-syncmal_0.62
- unpack malsync_2.0.6.src.tar.gz
-}
-
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ] ; then
- NLS_OPTION="--disable-nls"
- fi
-
- try ./configure --prefix=/usr --host=${CHOST} ${NLS_OPTION}
-
- # cheap fix?
- patch -p0 < ${FILESDIR}/${P}.patch
-
- # make sure we use $CFLAGS
- mv Makefile Makefile.old
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
-
- try make
-
- cd ${S}/jpilot-syncmal_0.62
- try ./configure --prefix=/usr --host=${CHOST}
- make
-}
-
-src_install() {
-
- make prefix=${D}/usr install
- insinto /usr/share/jpilot/plugins
- doins jpilot-syncmal_0.62/.libs/libsyncmal.so
- dodoc README TODO UPGRADING ABOUT-NLS BUGS\
- CHANGELOG COPYING CREDITS INSTALL
- doman docs/*.1
- newdoc jpilot-syncmal_0.62/ChangeLog ChangeLog.jpilot-syncmal
- newdoc jpilot-syncmal_0.62/README.1st README.1st.jpilot-syncmal
- newdoc jpilot-syncmal_0.62/README README.jpilot-syncmal
- dodoc jpilot-syncmal_0.62/malsync/Doc/README_AvantGo
- dodoc jpilot-syncmal_0.62/malsync/Doc/README_malsync
-
-
-}
-
diff --git a/app-misc/jpilot/jpilot-0.99.2-r1.ebuild b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
new file mode 100644
index 000000000000..0efcc3390664
--- /dev/null
+++ b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2-r1.ebuild,v 1.1 2002/05/28 06:32:55 seemant Exp $
+
+SYNCMAL="0.71"
+MALSYNC="2.0.7"
+S=${WORKDIR}/${P}
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+SRC_URI="http://jpilot.org/${P}.tar.gz
+http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz
+http://jasonday.home.att.net/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
+HOMEPAGE="http://jpilot.org/"
+
+# In order to use the malsync plugin you'll need to refer to the homepage
+# for jpilot-syncmal http://jasonday.home.att.net/code/syncmal/
+# And you'll also need an avangto account.
+
+DEPEND="=x11-libs/gtk+-1.2* >=dev-libs/pilot-link-0.9.5"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ unpack jpilot-syncmal_${SYNCMAL}.tar.gz
+ cd ${S}/jpilot-syncmal_${SYNCMAL}
+ unpack malsync_${MALSYNC}.src.tar.gz
+}
+
+src_compile() {
+
+ if [ -z "`use nls`" ] ; then
+ NLS_OPTION="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} ${NLS_OPTION} || die
+
+ # make sure we use $CFLAGS
+ mv Makefile Makefile.old
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
+
+ emake || die
+
+ # build malsync plugin
+ cd ${S}/jpilot-syncmal_${SYNCMAL}
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install() {
+
+ # work around for broken Makefile
+ dodir /usr/bin
+
+ make prefix=${D}/usr install
+
+ insinto /usr/lib/jpilot/plugins
+ doins jpilot-syncmal_${SYNCMAL}/.libs/libsyncmal.so
+
+ dodoc README TODO UPGRADING ABOUT-NLS BUGS CHANGELOG COPYING \
+ CREDITS INSTALL
+ doman docs/*.1
+
+ newdoc jpilot-syncmal_${SYNCMAL}/ChangeLog ChangeLog.jpilot-syncmal
+ newdoc jpilot-syncmal_${SYNCMAL}/README README.jpilot-syncmal
+ dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_AvantGo
+ dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_malsync
+
+}
+