summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-13 15:17:08 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-13 15:17:08 +0000
commit90491fb14d2b53ef7a70839eb7e2009358d3fc9e (patch)
treea5031ba335950f63f93dbd3ed4353af79b1c9a2d /app-misc/lsx/lsx-0.1.ebuild
parentAdd Apache herd to metadata. (diff)
downloadhistorical-90491fb14d2b53ef7a70839eb7e2009358d3fc9e.tar.gz
historical-90491fb14d2b53ef7a70839eb7e2009358d3fc9e.tar.bz2
historical-90491fb14d2b53ef7a70839eb7e2009358d3fc9e.zip
New ebuild for bug #151143
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-misc/lsx/lsx-0.1.ebuild')
-rw-r--r--app-misc/lsx/lsx-0.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/lsx/lsx-0.1.ebuild b/app-misc/lsx/lsx-0.1.ebuild
new file mode 100644
index 000000000000..ecdb9ba9b20a
--- /dev/null
+++ b/app-misc/lsx/lsx-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lsx/lsx-0.1.ebuild,v 1.1 2007/01/13 15:17:08 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="list executables"
+HOMEPAGE="http://tools.suckless.org/view/other+tools"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ # collision with net-dialup/lrzsz
+ mv "${D}/usr/bin/${PN}" "${D}/usr/bin/${PN}-suckless"
+
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Run ${PN} with ${PN}-suckless"
+}