summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-13 16:34:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-13 16:34:21 +0000
commit1b244e7165e59aa16723b343c3eb5fc9367be871 (patch)
treebb4a9238f612dc564e7994d15cbc52556660924d /app-misc/mouseremote/files
parentremove unused license (diff)
downloadhistorical-1b244e7165e59aa16723b343c3eb5fc9367be871.tar.gz
historical-1b244e7165e59aa16723b343c3eb5fc9367be871.tar.bz2
historical-1b244e7165e59aa16723b343c3eb5fc9367be871.zip
Apply separate patches gentoo patches for the two ebuilds. Thanks to Dane Smith for reporting it
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-misc/mouseremote/files')
-rw-r--r--app-misc/mouseremote/files/mouseremote-gentoo-0.90-r1.diff66
-rw-r--r--app-misc/mouseremote/files/mouseremote-gentoo.diff16
2 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/mouseremote/files/mouseremote-gentoo-0.90-r1.diff b/app-misc/mouseremote/files/mouseremote-gentoo-0.90-r1.diff
new file mode 100644
index 000000000000..d86902e37ed5
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote-gentoo-0.90-r1.diff
@@ -0,0 +1,66 @@
+diff -Naur MouseRemote.ORG/client/MouseRemote.conf MouseRemote/client/MouseRemote.conf
+--- MouseRemote.ORG/client/MouseRemote.conf Sat Oct 9 21:03:42 1999
++++ MouseRemote/client/MouseRemote.conf Sat May 4 16:04:43 2002
+@@ -61,3 +61,35 @@
+
+ # Definitions for the DVD device
+ [DVD]
++Power
++ChUp
++ChDown
++Mute
++VolUp
++VolDown
++Play
++Stop
++TxtRes
++Rew
++FF
++0
++1
++2
++3
++4
++5
++6
++7
++8
++9
++Ent
++Pause
++Last
++Disp
++AB
++Shift
++Guide
++Select
++TxtOff
++TxtTrns
++Rec
+diff -Naur MouseRemote.ORG/client/MouseRemoteKeys.pl MouseRemote/client/MouseRemoteKeys.pl
+--- MouseRemote.ORG/client/MouseRemoteKeys.pl Sun Oct 10 00:09:42 1999
++++ MouseRemote/client/MouseRemoteKeys.pl Sat May 4 15:58:58 2002
+@@ -11,6 +11,7 @@
+ play => 0x0d,
+ stop => 0x0e,
+ power => 0x0f,
++ txtres => 0x1b,
+ rew => 0x1c,
+ ff => 0x1d,
+ 0 => 0x40,
+@@ -31,11 +32,13 @@
+ 'shift' => 0x6b,
+ guide => 0x6d,
+ 'select' => 0x93,
++ txtoff => 0x9b,
++ txttrns => 0xeb,
+ rec => 0xff,
+
+ pc => 0x2b,
+- phone => 0x4b,
++ phone => 0x4b, # Marked as F2 on my model
+ web => 0x8b,
+ cd => 0xab,
+- dvd => 0xcb,
++ dvd => 0xcb, # Marked as F1 on my model
+ );
diff --git a/app-misc/mouseremote/files/mouseremote-gentoo.diff b/app-misc/mouseremote/files/mouseremote-gentoo.diff
index d86902e37ed5..5c0963859078 100644
--- a/app-misc/mouseremote/files/mouseremote-gentoo.diff
+++ b/app-misc/mouseremote/files/mouseremote-gentoo.diff
@@ -1,3 +1,19 @@
+diff -Naur MouseRemote.ORG/MultiMouse/Makefile MouseRemote/MultiMouse/Makefile
+--- MouseRemote.ORG/MultiMouse/Makefile Thu Aug 21 14:52:56 1997
++++ MouseRemote/MultiMouse/Makefile Sat May 4 15:49:16 2002
+@@ -20,10 +20,10 @@
+ -DMOUSE_FIFO=\"$(FIFO)\"\
+ -DLOCKDIR=\"$(LOCKDIR)\"\
+ -DMAX_MICE=$(MICE)
+-CFLAGS= $(OPTS)\
+- -O2 # -DDEBUG
+ LDLAGS= -O2
+
++OUTPUT_OPTION= $(OPTS) -o $@
++
+ all: $(TARGET)
+
+ multimoused: $(OBJS)
diff -Naur MouseRemote.ORG/client/MouseRemote.conf MouseRemote/client/MouseRemote.conf
--- MouseRemote.ORG/client/MouseRemote.conf Sat Oct 9 21:03:42 1999
+++ MouseRemote/client/MouseRemote.conf Sat May 4 16:04:43 2002