summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2003-08-21 21:02:17 +0000
committerLars Weiler <pylon@gentoo.org>2003-08-21 21:02:17 +0000
commit7574824c7daf7c170ef5ac55d9953dcf8265930b (patch)
tree6a01abc75a83d04c03cbb7d352a0ddf46088fba3 /app-misc/ondir/ondir-0.2.1.ebuild
parentinitial import (diff)
downloadhistorical-7574824c7daf7c170ef5ac55d9953dcf8265930b.tar.gz
historical-7574824c7daf7c170ef5ac55d9953dcf8265930b.tar.bz2
historical-7574824c7daf7c170ef5ac55d9953dcf8265930b.zip
initial import
Diffstat (limited to 'app-misc/ondir/ondir-0.2.1.ebuild')
-rw-r--r--app-misc/ondir/ondir-0.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/ondir/ondir-0.2.1.ebuild b/app-misc/ondir/ondir-0.2.1.ebuild
new file mode 100644
index 000000000000..3d7b0b1ff5d7
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ondir/ondir-0.2.1.ebuild,v 1.1 2003/08/21 21:02:07 pylon Exp $
+
+inherit eutils
+
+DESCRIPTION="ondir is a program that automatically executes scripts as you traverse directories."
+SRC_URI="http://ondir.sourceforge.net/${PV}/ondir-${PV}.tar.gz"
+HOMEPAGE="http://ondir.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+}
+
+src_compile() {
+ emake PREFIX=/usr CONF=/etc/ondirrc || die "Make failed"
+}
+
+src_install() {
+ ## EXEs
+ exeinto /usr/bin
+ exeopts -oroot -groot -m0755
+ doexe ondir
+ ## MISC
+ insinto /usr/share/${PN}
+ insopts -oroot -groot -m0755
+ doins scripts.sh scripts.tcsh
+ insopts -oroot -groot -m0644
+ doins ondirrc.eg
+ ## DOCS
+ dodoc \
+ AUTHORS \
+ ChangeLog \
+ COPYING \
+ INSTALL \
+ README \
+ TODO
+ doman \
+ ondir.1
+}