summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-10-25 13:57:02 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-10-25 13:57:02 +0000
commitab0c555b64ad4c816393f22b056bd9f639181b7b (patch)
treea65657db4ddbd3d7a732bc3005ebf2fa66c19261 /app-misc/ondir/ondir-0.2.2.ebuild
parentgpgme mask changes (diff)
downloadhistorical-ab0c555b64ad4c816393f22b056bd9f639181b7b.tar.gz
historical-ab0c555b64ad4c816393f22b056bd9f639181b7b.tar.bz2
historical-ab0c555b64ad4c816393f22b056bd9f639181b7b.zip
Version bump; updated HOMEPAGE and SRC_URI; respect user CFLAGS; use make install instead of a sleu of do* functions.
Diffstat (limited to 'app-misc/ondir/ondir-0.2.2.ebuild')
-rw-r--r--app-misc/ondir/ondir-0.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/ondir/ondir-0.2.2.ebuild b/app-misc/ondir/ondir-0.2.2.ebuild
new file mode 100644
index 000000000000..5f36394c90c3
--- /dev/null
+++ b/app-misc/ondir/ondir-0.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ondir/ondir-0.2.2.ebuild,v 1.1 2004/10/25 13:57:02 ka0ttic Exp $
+
+DESCRIPTION="program that automatically executes scripts as you traverse directories"
+HOMEPAGE="http://swapoff.org/OnDir"
+SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:\(/man/.*$\):/share\1:g" \
+ -e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CC="${CC:-gcc}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README INSTALL scripts.tcsh scripts.sh
+ newdoc ondirrc.eg ondirrc.example
+ dohtml changelog.html ondir.1.html
+}