summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-03 21:16:09 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-03 21:16:09 +0000
commitaa3b578b6a130a6fbaeeaa6ec16b9d3f80178aa7 (patch)
tree4205d75715e95dd4f388b6e96a7f80c02964ae0a /app-misc/pax-utils/pax-utils-0.2.3.ebuild
parentStabilize for all. (diff)
downloadhistorical-aa3b578b6a130a6fbaeeaa6ec16b9d3f80178aa7.tar.gz
historical-aa3b578b6a130a6fbaeeaa6ec16b9d3f80178aa7.tar.bz2
historical-aa3b578b6a130a6fbaeeaa6ec16b9d3f80178aa7.zip
Version bump.
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'app-misc/pax-utils/pax-utils-0.2.3.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-0.2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.2.3.ebuild b/app-misc/pax-utils/pax-utils-0.2.3.ebuild
new file mode 100644
index 000000000000..ae24d65084e5
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.2.3.ebuild,v 1.1 2011/03/03 21:16:09 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="caps"
+#RESTRICT="mirror"
+
+RDEPEND="caps? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_unpack() {
+ # avoid newer EAPI for easy upgrade paths
+ xz -dc "${DISTDIR}/${A}" | tar xf - || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" USE_CAP=$(use caps && echo yes) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS README TODO
+}