summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-17 05:34:36 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-17 05:34:36 +0000
commit7b963e531c6b4c53e688bc2edcce468e5a337f55 (patch)
tree24aeea160032471d4253edba9357944c06cb3230 /app-misc/rox
parentVersion Rev (diff)
downloadhistorical-7b963e531c6b4c53e688bc2edcce468e5a337f55.tar.gz
historical-7b963e531c6b4c53e688bc2edcce468e5a337f55.tar.bz2
historical-7b963e531c6b4c53e688bc2edcce468e5a337f55.zip
Fix (#1840)
Diffstat (limited to 'app-misc/rox')
-rw-r--r--app-misc/rox/rox-1.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/rox/rox-1.2.0.ebuild b/app-misc/rox/rox-1.2.0.ebuild
new file mode 100644
index 000000000000..172bd9452b84
--- /dev/null
+++ b/app-misc/rox/rox-1.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# /home/cvsroot/gentoo-x86/app-misc/rox/rox-1.1.8.ebuild $
+
+HOMEPAGE="http://rox.sourceforge.net"
+DESCRIPTION="ROX-Filer is a fast and powerful graphical file manager"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/rox/rox-base-1.0.1.tgz
+ http://prdownloads.sourceforge.net/rox/${P}.tgz"
+
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.0.3
+ >=x11-libs/gtk+-1.2.10
+ >=media-libs/gdk-pixbuf-0.13
+ dev-libs/libxml2"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+
+ # libxml2 header fix
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml -I/usr/include/libxml2"
+
+ cd ${WORKDIR}/rox-base-1.0.1/Choices
+ mkdir -p ${D}/usr/share/Choices
+ cp -rf MIME-icons/ ${D}/usr/share/Choices/
+ cp -rf MIME-info/ ${D}/usr/share/Choices/
+ cp -rf MIME-types/ ${D}/usr/share/Choices/
+
+ cd ${WORKDIR}/${P}
+ doman rox.1
+ mkdir -p ${D}/usr/share/rox
+ mkdir -p ${D}/usr/bin
+ cp -rf ROX-Filer/ ${D}/usr/share/
+ ${D}/usr/share/ROX-Filer/AppRun --compile
+ echo "#!/bin/sh" > "${D}/usr/bin/rox"
+ echo "exec /usr/share/ROX-Filer/AppRun \"\$@\"" >> "${D}/usr/bin/rox"
+ chmod a+x ${D}/usr/bin/rox
+
+}