summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2012-03-19 22:39:03 +0000
committerRichard Freeman <rich0@gentoo.org>2012-03-19 22:39:03 +0000
commitd7c838922298b7e82077642351f8b6206b46e509 (patch)
tree77f3b08aabe58626f8ad6d25306528401836c67f /app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild
parentPut sys-libs/mtdev in RDEPEND too, bug #408921. (diff)
downloadhistorical-d7c838922298b7e82077642351f8b6206b46e509.tar.gz
historical-d7c838922298b7e82077642351f8b6206b46e509.tar.bz2
historical-d7c838922298b7e82077642351f8b6206b46e509.zip
Add new package.
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild')
-rw-r--r--app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild b/app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild
new file mode 100644
index 000000000000..1db40c6fc759
--- /dev/null
+++ b/app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sleepyhead/sleepyhead-0.9.2.2.ebuild,v 1.1 2012/03/19 22:39:03 rich0 Exp $
+
+EAPI=4
+inherit eutils qt4-r2
+DESCRIPTION="Software used to analyze data from CPAP machines."
+HOMEPAGE="https://sourceforge.net/apps/mediawiki/sleepyhead/index.php?title=Main_Page"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="https://github.com/rich0/rich0-sleepyhead/tarball/${PV} -> ${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="virtual/opengl
+ x11-libs/libX11
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-opengl
+ x11-libs/qt-webkit"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/rich0-rich0-sleepyhead-86250b9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_prepare() {
+# qt4_src_prepare
+ cd "{$S}"
+ epatch "${FILESDIR}/gitfix.patch"
+ epatch "${FILESDIR}/prs1-64fix.patch"
+ eqmake4 SleepyHeadQT.pro
+}
+
+src_install() {
+ cd "{$S}"
+ dobin SleepyHead || die
+ dodoc README || die
+ dodoc docs/* || die
+}