summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-09-29 07:11:28 +0000
committerPeter Volkov <pva@gentoo.org>2007-09-29 07:11:28 +0000
commit706c1ae66984250a62981ccc5e71bac99fa5219f (patch)
tree68fc13c51c12a8e61bba4c3a12575d8e962ed2ce /app-misc/symlinks/symlinks-1.2-r1.ebuild
parentold (diff)
downloadhistorical-706c1ae66984250a62981ccc5e71bac99fa5219f.tar.gz
historical-706c1ae66984250a62981ccc5e71bac99fa5219f.tar.bz2
historical-706c1ae66984250a62981ccc5e71bac99fa5219f.zip
Use tc-getCC compiler, fixes bug #193245, reported by Chris Slycord <cslycord AT gmail.com>
Package-Manager: portage-2.1.3.10
Diffstat (limited to 'app-misc/symlinks/symlinks-1.2-r1.ebuild')
-rw-r--r--app-misc/symlinks/symlinks-1.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/symlinks/symlinks-1.2-r1.ebuild b/app-misc/symlinks/symlinks-1.2-r1.ebuild
new file mode 100644
index 000000000000..f806c4952aad
--- /dev/null
+++ b/app-misc/symlinks/symlinks-1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/symlinks/symlinks-1.2-r1.ebuild,v 1.1 2007/09/29 07:11:27 pva Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Symlinks scans for and fixes broken or messy symlinks"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/utils/file/"
+SRC_URI="http://www.ibiblio.org/pub/linux/utils/file/${P}.tar.gz
+ mirror://debian/pool/main/s/symlinks/${P/-/_}-4.1.diff.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_unpack() {
+ unpack ${A}
+
+ # bugfixes from the debian project.
+ epatch "${DISTDIR}"/${P/-/_}-4.1.diff.gz
+}
+
+src_compile() {
+ # could be useful if being used to repair
+ # symlinks that are preventing shared libraries from
+ # functioning.
+ use static && append-flags -static
+ emake || die
+}
+
+src_install() {
+ dobin symlinks || die
+ doman symlinks.8
+ dodoc symlinks.lsm
+}