summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-23 16:29:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-23 16:29:16 +0000
commit2eca0cbf03dbd7d98b8efedaaff725f6ff207e88 (patch)
treef03c60a06f309d448ab7f487d396e1f65bf179aa /app-misc/ytree/ytree-1.92-r2.ebuild
parentSpecial case another LINGUAS combination until we have a better (diff)
downloadhistorical-2eca0cbf03dbd7d98b8efedaaff725f6ff207e88.tar.gz
historical-2eca0cbf03dbd7d98b8efedaaff725f6ff207e88.tar.bz2
historical-2eca0cbf03dbd7d98b8efedaaff725f6ff207e88.zip
Respect CC (bug #243684) and LDFLAGS.
Package-Manager: portage-2.2_rc63/cvs/Linux i686
Diffstat (limited to 'app-misc/ytree/ytree-1.92-r2.ebuild')
-rw-r--r--app-misc/ytree/ytree-1.92-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/ytree/ytree-1.92-r2.ebuild b/app-misc/ytree/ytree-1.92-r2.ebuild
new file mode 100644
index 000000000000..0dd8fb35a624
--- /dev/null
+++ b/app-misc/ytree/ytree-1.92-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ytree/ytree-1.92-r2.ebuild,v 1.1 2010/02/23 16:29:15 jer Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A (curses-based) file manager"
+HOMEPAGE="http://www.han.de/~werner/ytree.html"
+SRC_URI="http://www.han.de/~werner/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ytree
+ doman ytree.1
+}