summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-07-03 07:43:27 +0000
committerAlin Năstac <mrness@gentoo.org>2005-07-03 07:43:27 +0000
commitce73513873028f08b84b96ad7003733d52d4bc0a (patch)
tree4b13d616e52963e89951e01ce368d16f2e704063 /app-mobilephone/gammu/gammu-1.01.0-r1.ebuild
parent060 release (diff)
downloadhistorical-ce73513873028f08b84b96ad7003733d52d4bc0a.tar.gz
historical-ce73513873028f08b84b96ad7003733d52d4bc0a.tar.bz2
historical-ce73513873028f08b84b96ad7003733d52d4bc0a.zip
fix callergroup on Nokia 6230 (#97603)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-mobilephone/gammu/gammu-1.01.0-r1.ebuild')
-rw-r--r--app-mobilephone/gammu/gammu-1.01.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild b/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild
new file mode 100644
index 000000000000..9f0edb3e505b
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.01.0-r1.ebuild,v 1.1 2005/07/03 07:43:27 mrness Exp $
+
+inherit eutils
+
+MY_MAJOR_VER=${PV:0:3}
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+SRC_URI="http://www.mwiacek.com/zips/gsm/${PN}/stable/${MY_MAJOR_VER/./_}x/${P}.tar.gz"
+HOMEPAGE="http://www.gammu.net/projects/gammu.php"
+
+IUSE="bluetooth irda mysql nls ssl"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ bluetooth? ( net-wireless/bluez-libs )"
+
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-caller.patch
+}
+
+src_compile() {
+ local myconf
+ use bluetooth && myconf="${myconf} --with-bluedir=/usr/lib" \
+ || myconf="${myconf} --disable-bluefbus --disable-blueobex --disable-bluephonet --disable-blueat --disable-bluerfsearch --disable-fbusblue"
+ use irda || myconf="${myconf} --disable-irdaat --disable-irdaphonet"
+ sed -e 's:-lbluetooth -lsdp:-lbluetooth:g' \
+ -i ${S}/cfg/autoconf/configure.in
+ econf \
+ `use_enable nls` \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ --enable-6210calendar \
+ ${myconf} || die "configure failed"
+
+ sed -e 's:-lz -pthread:-lz -lpthread -lssl:g' \
+ -i ${S}/cfg/Makefile.cfg
+ emake || die "make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} installlib || die "install failed"
+ doman docs/docs/english/gammu.1
+ mv ${D}/usr/share/doc/${PN} ${D}/usr/share/doc/${P}
+}