summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-03-22 00:04:28 +0000
committerMarinus Schraal <foser@gentoo.org>2005-03-22 00:04:28 +0000
commitc14ce39086867b15b2c96eb12123bbb952f0cc7f (patch)
tree9f22b0303008c290ab247a24ee6d69c43a311647 /app-office/abiword
parentadded ~amd64 to KEYWORDS. fixes #80338 (diff)
downloadhistorical-c14ce39086867b15b2c96eb12123bbb952f0cc7f.tar.gz
historical-c14ce39086867b15b2c96eb12123bbb952f0cc7f.tar.bz2
historical-c14ce39086867b15b2c96eb12123bbb952f0cc7f.zip
mark 2.2.3 x86, new release
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/Manifest4
-rw-r--r--app-office/abiword/abiword-2.2.3.ebuild6
-rw-r--r--app-office/abiword/abiword-2.2.5.ebuild104
-rw-r--r--app-office/abiword/files/digest-abiword-2.2.51
4 files changed, 111 insertions, 4 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index c003108e0088..cb23b48cf9a2 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,4 +1,5 @@
-MD5 ddfc7274b38a20045d5475c5393c7bf7 abiword-2.2.3.ebuild 2259
+MD5 5ffc39b07bcd9fd58400f4e704d31f47 abiword-2.2.3.ebuild 2294
+MD5 498d6eaacd8ef30cb5e7899581d45be5 abiword-2.2.5.ebuild 2286
MD5 728e85c3f04c02a833f996e3a6ecfbdf abiword-2.0.10.ebuild 2440
MD5 9ba3c56a7ac3936cbf08b6f956b1ce2f abiword-2.2.2.ebuild 2262
MD5 eedba3f653f06a9891f2aba56e449984 ChangeLog 13745
@@ -6,3 +7,4 @@ MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 4b3719f3158acf5c443b4739886272f4 files/digest-abiword-2.0.10 69
MD5 3b6aacecf03d65d9c41833afe9d29687 files/digest-abiword-2.2.2 68
MD5 b99de998f7d17ea36a6f83bea33406be files/digest-abiword-2.2.3 68
+MD5 05bd382bc17a222b7d38e46dd90350c0 files/digest-abiword-2.2.5 68
diff --git a/app-office/abiword/abiword-2.2.3.ebuild b/app-office/abiword/abiword-2.2.3.ebuild
index d70695975816..62b1c97dad78 100644
--- a/app-office/abiword/abiword-2.2.3.ebuild
+++ b/app-office/abiword/abiword-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.2.3.ebuild,v 1.2 2005/03/06 19:00:49 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.2.3.ebuild,v 1.3 2005/03/22 00:04:28 foser Exp $
inherit eutils fdo-mime
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.abisource.com"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-KEYWORDS="~x86 ~sparc ~alpha ~ppc amd64 ~hppa ~ppc64"
+KEYWORDS="x86 ~sparc ~alpha ~ppc amd64 ~hppa ~ppc64"
LICENSE="GPL-2"
SLOT="2"
@@ -79,7 +79,7 @@ src_install() {
dodir /usr/{bin,lib}
- make DESTDIR=${D} install || die
+ CFLAGS="${CFLAGS} -DHAVE_NAUTILUS=0" make DESTDIR=${D} install || die
dosed "s:Exec=abiword:Exec=abiword-2.2:" /usr/share/applications/abiword.desktop
diff --git a/app-office/abiword/abiword-2.2.5.ebuild b/app-office/abiword/abiword-2.2.5.ebuild
new file mode 100644
index 000000000000..bc1701bfd510
--- /dev/null
+++ b/app-office/abiword/abiword-2.2.5.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.2.5.ebuild,v 1.1 2005/03/22 00:04:28 foser Exp $
+
+inherit eutils fdo-mime
+
+IUSE="gnome jpeg spell xml2 debug"
+
+S_P=${S}/${PN}-plugins
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64 ~hppa ~ppc64"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )
+ !xml2? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2.1
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonobo-2
+ >=gnome-extra/gucharmap-1.4 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ # this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
+ # The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
+ cp configure configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
+
+ econf \
+ `use_enable gnome` \
+ `use_enable gnome gucharmap` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+ econf \
+ `use_enable debug` \
+ --enable-all \
+ --with-abiword=${S} \
+ --without-ImageMagick || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ make DESTDIR=${D} install || die
+
+ dosed "s:Exec=abiword:Exec=abiword-2.2:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.2
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.2 /usr/bin/abiword-2.2
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+}
+
+pkg_postinst() {
+
+ fdo-mime_desktop_database_update
+
+}
diff --git a/app-office/abiword/files/digest-abiword-2.2.5 b/app-office/abiword/files/digest-abiword-2.2.5
new file mode 100644
index 000000000000..2d79096e30b0
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.2.5
@@ -0,0 +1 @@
+MD5 265a6ece8fcfd37cb7c3fc4d13056ad2 abiword-2.2.5.tar.bz2 23740589